cancel
Showing results for 
Search instead for 
Did you mean: 

Sender SOAP Adapter with HTTPs call

former_member189558
Contributor
0 Kudos

Hello,

Our scenarion is .. we will have a sender SOAP adater .. but it needs to be called using HTTPs(SSL).

Now considering we have the certificate generated and installed ..and that integration server is HTTPs enabled....What URL should the sending system call..?

For normal HTTP call the inbound address for inbound Adapter is: http://host:port/XISOAPAdapter/MessageServlet?channel=party:service:channel

For the case of HTTPs just changing the htttp to https and the port number in in the calling system will suffice? Or is there other configurations that needs to be done??

Thanks and Regards,

Himadri

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Himadri,

Firstly as suggested by others you can call using https and give the https port in the soap adapter servler URL. Secondly you need to do the following configurations:

1) If its PI 7.0/3.0, deploy the latest version of the SAP Java cryptography toolkit.

2) Configure SAP PI as the server for HTTPS calls. In short

Using the SSL Provider service:

a. Select whether the J2EE Engine should:

■ Request (but not require) that the user presents a client certificate for authentication.

■ Require that client certificates are to be used for authentication.

b. Import the CAu2019s root certificate into the Trusted Certification Authorities list. (Choose Add.) using the following For all the steps, link is mentioned below for XI 3.0, you can find similar ones for PI 7.0

http://help.sap.com/saphelp_nw04/helpdata/en/f1/2de3be0382df45a398d3f9fb86a36a/content.htm

3) If you want to enable client authentication then you would need to add the client certificate in the TrustedCA keystore view of the SAP J2EE engine.

4) In the SOAP Adapter sender channel, configure Inbound Security level as HTTPS or HTTPs with client authentication based on your scenario.

Best Regards,

Pratik

Former Member
0 Kudos

Hello Himadri,

It will be worth going through this, in case you haven't had the exchange profile configured - http://help.sap.com/saphelp_nw04/helpdata/en/14/ef2940cbf2195de10000000a1550b0/frameset.htm

Best of luck with your scenario!

Neetesh

former_member568822
Active Participant
0 Kudos

Hi,

Just change the http to https and also the port to https port for the url.

Best regards.