cancel
Showing results for 
Search instead for 
Did you mean: 

Seeking Assistance with Fiori ListReport App Grid Table Multiselect Options

TedP
Explorer
0 Kudos
182

Hello,

I am currently in the process of developing a Fiori ListReport application and I am aiming to have my table type set as a grid table with multiselect options. I have been creating the ListReport using the Fiori ListReport template in Web IDE, and I am working with UI5 version 1.78.9.

Here is how my manifest.json for table settings is currently configured:

"tableSettings": {
              "type": "GridTable",
              "multiSelect": true,
              "selectAll": true
            }

When I preview the application using the "npm run start" command, everything appears to be in order and nothing seems to be missing. However, when I deploy the application, the checkboxes that should allow for the selection of records are nowhere to be found. It appears as though the table settings were not deployed correctly, as I am able to enable the multiselect option via the web DevTool console using the command: sap.ui.getCore().byId(GridTableName)._getSelectionPlugin().setSelectionMode('MultiToggle').

I have also attempted to resolve this issue by adjusting the table setting to "selectionMode": "MultiToggle" and upgrading the UI5 version, but neither of these solutions have resulted in any changes.

I am hopeful that someone in this forum may have some suggestions or insights that could assist me in resolving this issue.

Best regards,

 
View Entire Topic
Willem_Pardaens
Product and Topic Expert
Product and Topic Expert

Hi,

First of all I suggest to update your UI5 version to a supported version (see list here: https://sapui5.hana.ondemand.com/versionoverview.html)

If the issue still persists afterwards: where do you deploy the application to? The runtime environment might dictate which ui5 version is used for your application.

TedP
Explorer
0 Kudos

Hey,

higher versions of UI5 doesn't solve the problem. Our runtime enviroment dictates the version 1.78.9 of UI5. 

Do you have any other suggestions ?