Showing results for 
Search instead for 
Did you mean: 

SDM password issue

Former Member
0 Kudos


From my NW studio, I am not able to deploy my web dynpro applications directly into SDM. Somehow the password is not correct. Here are few things I tried & don't know where to go from here....

1) Changed the password of SDM using the changepassword command. Restarted J2EE server, NW studio & tried new password I still get the following error...

Used following command:

C:\usr\sap\JKS\JC00\SDM\program>sdm changepassword "sdmhome=C:/usr/sap/JKS/JC00/SDM/program" "newpassword=abc123"

2)Changed the hash in the sdmrepository.sdc file & restarted J2EE server. Then used "sdm" as the password but still didn't help.

In both cases I get similar logs. Here is the log message in NW studio:


Apr 21, 2005 11:59:35 AM /userOut/deploy ( [Thread[Deploy Thread,5,main]] ERROR:

[001]Deployment aborted


SDM host : sapdemo

SDM port : 50118

URL to deploy : file:/C:/DOCUME1/sachin/LOCALS1/Temp/temp23444test1.ear


=> deployment aborted : file:/C:/DOCUME1/sachin/LOCALS1/Temp/temp23444test1.ear

Aborted: development component 'test1'/'local'/'LOKAL'/'0.2005.':

Caught exception while checking the login credentials for SAP J2EE Engine. Check whether the SAP J2EE Engine is up and running. ERROR: Cannot connect to Host: [sapdemo] with user name: [Administrator] Check your login information. Exception is: Exception while trying to get InitialContext. [Root exception is User not authorized.]

(message ID:

Deployment exception : The deployment of at least one item aborted


Does SDM password has to match with any other password? Thanks


Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Sach,

I suppose you've changed the J2EE admin password but not updated it in the secure storage on the file system. Please follow SAP note 701654 and try to deploy again.

Hope it helps!


Former Member
0 Kudos

Thanks Vladimir. It worked.

So the issue was that SDM was not able to connect to J2EE server because I changed the j2ee server password. Unfortunately SDM uses the password stored in the secure file store to connect to j2ee server. The change of password did not update this password stored in the file store. So SDM was not able to connect to J2EE server. The error message thrown by SDM says user not authorized but did not indicate anything regarding not being able to connect to j2ee server.

Anyway applying note 701654 solved the issue.

Answers (2)

Answers (2)

Former Member
0 Kudos


I had a similar problem and tried all the various suggestions given on this forum. The only one that worked for me was to go into the "sdmrepository.doc" file and put in the hashed value of "sdm" into the <HashedPassword> entry.

I found the file in the following path of my locally installed NDS:


The hashed value is "yPLDEBe3oOb6H2mmjJ0zztOgw/A="

So your final entry should look like this:


Make sure you stop the server before doing this. Not sure why, but I had to stop/restart the server a couple of times before it recognized the change.

Hope it works as well for you as it did for me


Former Member
0 Kudos


First please check weather you can able to login via SDM gui or not.(C:\usr\sap\C11\JC02\SDM\program)

Second check weather you can able to login to VisualAdministrator through "Administrator" user.

If both works then ideally it should not create any problems while deployment !!

Workaround is you can deploy the app throughVisualAdministrator (using Deploy service)

Regards, VIP