cancel
Showing results for 
Search instead for 
Did you mean: 

SDM in CE

Former Member
0 Kudos
55

Hi buddies,

I can't find SDM in CE when I tried to deploy a webdynpro application.Can anybody tell me where is SDM or how can I deploy the application in CE?

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

After I installed NW2004 I found the SDM service.

Former Member
0 Kudos

Hi Steven,

Please open Windows>Show view>Deploy View -->Deploy View in

IDE.In this view you can deploy your CE application.

Thanks and Regards

Ashis

Former Member
0 Kudos

Hi Ashis,

I didn't found Deploy View -->Deploy View in my IDE.

My netweaver developer studio's version is 7.0.0.9

Former Member
0 Kudos

Hi Steven,

Use 7.2.0 version of Dev studio for CE environment.

Thanks and Regards

Ashis

pankaj_bisht
Contributor
0 Kudos

Hi Steven.

Go to Web Dynpro Perspective.

Go to your Web dynpro Application and Select "Deploy new archive and run"

or Select your Web Dynpro Project and Deploy and then Run the Application.

Make Sure your Host and port is maintained correctly in Window-> Preferences-> SAP AS Java.

You Can check in the UnDeploy View to check whether your application is deployed or not.

Regards

Pankaj

Former Member
0 Kudos

Hi Steven,

SDM has been discontinued as of SAP NetWeaver CE.

Check thread for more info on replacement tools for deployment.

Former Member
0 Kudos

Hi Ivaylo,

I followed the guide to deploy my application but I didn't find <b>Run on server</b> button in my developer studio.

1. Click with the secondary mouse button on the application in the Project Explorer view.

2. From the pop-up menu, select Run As -> <b>Run on Server</b>. The Define a New Server view of the Run on Server dialog box appears.

3. Define a server. You can:

Choose an existing server

Manually define a new server.

4. Click Next. The Add and Remove Projects view of the Run on Server dialog box appears with the application already moved to the Configured Projects list.

5. Click Finish.

Former Member
0 Kudos

Hi Ivaylo,

When I was deploying a webdynpro application on developer studio I encountered an error:

Oct 17, 2007 2:03:39 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

[001]Deployment aborted

Deployment exception : Cannot determine sdm host (is empty). Please configure your engine/sdm correctly !

but my J2EE engine window is geen light.

When I click Run button on this application,the system warned me that the j2ee server and port number are not configured correctly.

Former Member
0 Kudos

Hi Steven,

Check if you use the right port in your DevStudio preferences for AS Java.

It is possible when you use a wrong port, that you get as well green lights.

But you have to see as well the SDM Service with a green light in your console.

regards,

robin

Former Member
0 Kudos

Hi Robin,

I didn't found SDM service in my SAP NetWeaver Composition Environment 7.1 Trial Version system.