cancel
Showing results for 
Search instead for 
Did you mean: 

Script Validation Error

former_member192236
Participant
0 Kudos

Hello Experts,

I am facing a strange issue in SAP Design Studio 1.3 SP1

When i execute dashboard from Platform, I get 'Script Validation Error'. But i am not getting this error when i execute locally. View -> Script Problem is not showing up any errors either.

What could be the problem here ? Is there a way to look at the detailed message of the error like where exactly is the script error points out i.e. on which line etc. etc.,

Thanks & Regards,

Kesavan.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi

I am experiencing the same problem - have you been able to resolve it?

Both my script problems and error logs are empty.

Kind regards 

Former Member
0 Kudos

Hi

This problem is solved for me now.

I eventually found the log and saw it was complaining about all my API statements when executed on the BI platform e.g. substring, convert. etc.

I restarted all services and the problem was resolved.

regards

former_member192236
Participant
0 Kudos

Hi Stephen,

Thanks a lot for sharing.

I have not done anything, the error stopped popping up after couple of  days and it started occuring again after couple of days and then it stopped ultimately. It was intermittent and not sure why it is unstable like this.

Now there is no error.

Thanks & Regards,

Kesavan.

Former Member
0 Kudos

No problem Kesavan

Will you consider closing the thread as answered - it certainly seems as though we had the same issue and have a temporary solution.

if it occurs again, I am also logging a separate SAP ticket for it.

Regards

Stephen

former_member192236
Participant
0 Kudos

Hi Stephen,

I face the same issue again now but for a different dashboard.

Did you face this issue after ?

Thanks,

Kesavan.

Former Member
0 Kudos

Hi Kesavan

No, it has not occurred again for me. Have you tried restarting the all servers (or I propose you do the main ones, one-by-one, to identify the one that's really required to be restarted).

Regards

reiner_hille-doering
Active Contributor
0 Kudos

I have just updated note http://service.sap.com/sap/support/notes/2079054 .

In 1.3 we have a ZTL file ending with /////.

It can happen that an SDK ZTL file is appended and thus its content is lost.

Release 1.4 and later detect such issues and emmit good error messages.

reiner_hille-doering
Active Contributor
0 Kudos

If the error appear on the platform only, you need someone to look into the BI platform log files. Search there for the log ID that is shown on the message view.

There could be a view reasons, including an installed - but not necessarily used - SDK component that has some bad content. This is what the note is about the Tammy mentioned.

TammyPowlas
Active Contributor
0 Kudos

Please look at View > Script Problems or View > Error Log - what does it say?  It could be something is not loaded to the BI platform with your application

former_member192236
Participant
0 Kudos

Hi Tammy,

Script Problem has no entry.

Error Log says 'Automatix relogin has failed'. Nothing else.

It used to work until yesterday. All of sudden something happened today.

Is there a way to check the log of that error using the Log ID (Alphanumeric number) to understand or check where the system validates the script and finding this error i.e. on which line etc. etc.,

"Details logged using ID 5bf42bec-09dd-475a-a840-692f2fc254f4"

Thanks & Regards,

Kesavan.

TammyPowlas
Active Contributor
0 Kudos

Hello Kesavan - I don't know how to read those log details; hopefully someone else can reply with more or better information.

Only thing I did find was this note -

http://service.sap.com/sap/support/notes/2079054

Might your application be impacted?

Tammy