Showing results for 
Search instead for 
Did you mean: 

Scheduled Crystal Report failing

Former Member
0 Kudos


we have an Edge 3.1 SP3 server running a Crystal Report which is pulling data via a universe from a spreadsheet saved on the C: of the server itself.

The schedule was running successfully up until last Friday and emailing results to users as a pdf.

On Monday and every day since the schedule failed. The failure reason is given as - Error in file ~tmp####.rpt Failed to retrieve data from the database.

If I try to 'view' the report to refresh it manually it comes up with an error: Error in File Daily Support Report: Encapsulating page failed.

If I try to open and refresh the Crystal Report file locally in CR 2008 I am prompted to logon to the BO installation but when I try to refresh the report it fails and returns a blank page.

I can write new Crystal Reports on the efashion universe from that installation, but not on this other universe - I can build a query from it but it will not run.

I tried to save a new version of the report from my locally saved copy to the Enterprise location, but that report will not open to view either, it fails with the same message.

However I CAN create and refresh Web Intelligence queries on this universe - so I have checked all the connections and set up for the universe and they are correct.

I have since installed SP4 (following a suggestion in a SAP note that this is linked to a bug fixed in FP3.4) but I still cannot open the Crystal report to view it.

All the services are up and running, no fix packs have been applied to SP3 or 4, there have been no recent Windows updates between the last successful instance and the first failure. Have rebooted the server, restarted the SIA etc.

Anyone got any ideas?



Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos


As you have already tried many options, please try to do the following stuff, by reading your problem it seems the report is corrupted.

1. Try to repoint the connection and save it

2. Check if you FileStore both input and output has space.

3. Try enabling CMS trace or crystal report server trace to see the exact problem.