cancel
Showing results for 
Search instead for 
Did you mean: 

SBP installation fails miserably

symon_braunbaer
Participant

Dear experts,

I am installing a new Solution Manager system on Oracle DB. Therefore I am installing two Oracle instances.
One for ABAP and one for Java.
The installation of the first instance went flawlessly and I could apply the latest SBP patch without any issue.
I have also installed the second Oracle instance for the Java system without any problems. However, when I
wanted to apply the same SBP patch, it fails miserably:

Processing patch "GIRU19P_2402-70004506.ZIP!35940989!35943157"...(3 of 32)
Adding missing write permissions for patch copy target "/oracle/SSJ/19.0.0/jdk/jre/bin/java".
Processing patch "GIRU19P_2402-70004506.ZIP!35940989!35943157"...failed.
Reason: Cannot apply patch.

When I check the opatch log file, it gives the error, but no suggestion as how to fix it and it leaves me clueless, I couldn't find anything I could try even after googling a lot and asking ChatGPT for help:

Stack Description: java.lang.RuntimeException:
Prerequisite check "CheckApplicable" failed.
at oracle.opatch.OPatchSessionHelper.runApplyPrereqs(OPatchSessionHelper.java:6612)
at oracle.opatch.opatchutil.NApply.legacy_process(NApply.java:988)
at oracle.opatch.opatchutil.NApply.legacy_process(NApply.java:373)
at oracle.opatch.opatchutil.NApply.process(NApply.java:353)
at oracle.opatch.opatchutil.OUSession.napply(OUSession.java:1139)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:508)
at oracle.opatch.UtilSession.process(UtilSession.java:355)
at oracle.opatch.OPatchSession.process(OPatchSession.java:2643)
at oracle.opatch.OPatch.process(OPatch.java:874)
at oracle.opatch.OPatch.main(OPatch.java:931)
Caused by: java.lang.RuntimeException:
Prerequisite check "CheckApplicable" failed.
... 13 more
Caused by: oracle.opatch.PrereqFailedException:
Prerequisite check "CheckApplicable" failed.
... 13 more

 

I only had one more idea - I tried to roll back that patch, but I am not sure if I am doing it correctly:

% /oracle/SSJ/19.0.0/OPatch/opatch rollback -id 35940989
========================================================
GENERIC OPATCH VERSION - FOR USE IN SAP ENVIRONMENT ONLY
========================================================
Oracle Interim Patch Installer version 12.2.0.1.40
Copyright (c) 2024, Oracle Corporation. All rights reserved.

Argument(s) Error... Patch not present in the Oracle Home, Rollback cannot proceed
If the patch was applied using -no_inventory option, use -ph option
to specify the patch shiphome location. Use 'opatch rollback -help'
to get more information.

Please check the arguments and try again.

OPatch failed with error code 135
% /oracle/SSJ/19.0.0/OPatch/opatch rollback -id 35943157
========================================================
GENERIC OPATCH VERSION - FOR USE IN SAP ENVIRONMENT ONLY
========================================================
Oracle Interim Patch Installer version 12.2.0.1.40
Copyright (c) 2024, Oracle Corporation. All rights reserved.

Argument(s) Error... Patch not present in the Oracle Home, Rollback cannot proceed
If the patch was applied using -no_inventory option, use -ph option
to specify the patch shiphome location. Use 'opatch rollback -help'
to get more information.

Please check the arguments and try again.

OPatch failed with error code 135

 

Any help will be very appreciated!

View Entire Topic

Hi Symon,

Are you sure you checked the correct opatch log? If you did, I suggest to open a ticket at SAP, as this needs to be further investigated.

But in general I suggest you to check the mopatch log as follows:

- check the failed GIRU patch entry in mopatch log

- scan lines before and after the fail for more specific information and the exact name of the opatch log

- check the complete opatch log

But if you did this already and still not found anything, the best bet is to open a ticket.