cancel
Showing results for 
Search instead for 
Did you mean: 

SAPSYSTEMNAME neither in Profile nor Commandline with r3trans

former_member197700
Participant
0 Kudos
14,223

Hello gurus,

Where in Windows or in SAP do I need to set the SAPSYSTEMNAME parameter so I don't see this message with r3trans?

R3trans=>sapparam: SAPSYSTEMNAME neither in Profile nor Commandline with r3trans

Warm Regards,

CM

Accepted Solutions (1)

Accepted Solutions (1)

Former Member

Hi Clifton,

After searching a lot, i found this note relevant to your issue - Note 32785

Summary

Symptom

Various unix programs return the message on startup       sapparam(1c): No Profile used.
      sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

Additional key words

Cause and prerequisites

Many shell programs (example: sapevt) are started with parameters.       <program> pf=<profile>or       <program> name=<hostame> nr=<instance>
The program sapparam is started automatically, to test system parameters. If the program is started with the parameters hostname and instance, the following message appears:       sapparam(1c): No Profile used.

Solution

This message is only a minor flaw that can be simply ignored.

As specified here, this message can be ignored as this is just a warning and not an error.

Hope this helps,

Regards,

Ashutosh Shukla

Answers (5)

Answers (5)

former_member183107
Contributor
0 Kudos

Hi Clifton,

Login with SIDADM and use R3trans -d.

Regards,

Himanshu

former_member197700
Participant
0 Kudos

SAPSYSTEMNAME is set properly for <sid>adm and all users.  I would prefer not to paste my  system envrionment here. Are there a couple of specific variables you are interested in?  If anyone has further suggestions for how to suppress this message, I would appreciate it because it is quite annoying.  Otherwise, I will take the advice of Ashutosh and ignore it.

Former Member
0 Kudos

Hi Clifton ,

Are there any further clues in the trans.log file ?

If possible can you paste it here ?

The error could also possibly be because of insufficient authorizations for OPS$ users.

Are there any other problems within the system like backup failures which may suggest this ?

Just in case, Check this note

Note 400241 - Problems with ops$ or sapr3 connect to Oracle

and other similar notes for your OS and DB

Former Member
0 Kudos

It's been a while since I used tp or R3trans directly, but I guess you could use both the profile parameter as well as the hostname and instance parameters with the command to suppress all warnings, but that seems to be more cumbersome to me than just ignoring the warnings.

I am curious why you are using R3trans on the command line.  Most functionality was moved to ABAP based tools by R/3 4.6C.

former_member197700
Participant
0 Kudos

Hi Susan,

What syntax could I use to add the hostname and instance parameters to the R3trans command?  I do not find an option with R3trans that allows this.  With tp, you can specify pf=, but with R3trans, I found that it ignores additional options.

R3trans is used in custom scripts for exporting and importing tables for homogenous system copy.

former_member197700
Participant
0 Kudos

When I run a lot of r3trans commands, it adds unnecessary noise to the output.  I will happily add a flag to the r3trans string or use any profile it wants, I just need to know how.  ... or is that every customer that uses r3trans will see these informational messages and there is no way to get rid of them?

Former Member
0 Kudos

Hi,

Just to check, are the environment variables set accordingly for the <sid>adm windows user?

Regards,

Srikishan

Former Member
0 Kudos

Hi Clifton,

Please do following:

1. go to SE38

2. run Program RSBDCOS0

3. enter env and paste output here

4. enter set and paste output here

Thanks, Premlesh

Former Member
0 Kudos

1)download and replace latest R3trans and check .

2) run tx se38 >rspfpar report , check SAPSYSTEMNAME

Former Member
0 Kudos

R3trans searchs parameters in system environment. So please set SAPSYSTEMNAME in global environment.

former_member197700
Participant
0 Kudos

I set SAPSYSTEMNAME to BDR in the system environment variables and rebooted.  I see the same message:


C:\Documents and Settings\bdradm>r3trans -d
This is r3trans version 6.22 (release 720 - 18.11.11 - 11:29:00).
unicode enabled version
R3trans=>sapparam(1c): No Profile used.
R3trans=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
r3trans finished (0000).

C:\Documents and Settings\bdradm>set SAPSYSTEMNAME
SAPSYSTEMNAME=BDR

DEFAULT.PFL already has SAPSYSTEMNAME=BDR too, yet I am still seeing this message.

Former Member
0 Kudos

I can see this is only a warning so can be ignored.