cancel
Showing results for 
Search instead for 
Did you mean: 

sapstartsrv service reports the service would not start after 40 seconds

Former Member
0 Kudos

I am upgrading my Solution manager system to V7.1 and am in the Down time phase.

The SAPup is attempting to start the SAP<sid>_<instance number> service with sapstartsrv

sapstartsrv reports that it could not start the service after 40 seconds and the upgrade stops.

When I check the service in the Windows Management Console services, I see that the service is started.

When I execute the sapstartsrv manually I get the same message about the service not starting after 40 seconds.  However, while it is running I can see the service is in the "STARTING" mode and finally starts after about 70 seconds.

Does anyone know how to disable or change the timeout for sapstartsrv during the upgrade?  Or is there something else I can do to speed up the service start.

The system is currently running Windows Server 2003, x64, Service Pack 2.

View Entire Topic
former_member182034
Active Contributor
0 Kudos

hi Doug,

The SAP Note 142100 lists all known problems and solutions related to the start service.

the following link might be helpful to troubleshoot the issue.

sapstartsrv

Regards,

Former Member
0 Kudos

Hi Ma Jamil,

SAP finally responded.  They had me delete/rename 4 files in the \usr\sap\<SID>\<instance>\log directory - ALAGENTALERTS, ALALERTS, ALMTTREE, and ALPERFHI.

The service started immediately when I manually executed sapstartsrv.

I then restarted the upgrade and it quickly moved on to the next step which is to backup the database.

SAP suggested that "These files are probably corrupted and might be deleted as they are

loaded from DB during a start of the system." (thanks to John Feely from SAP)

former_member182034
Active Contributor
0 Kudos

hi Doug,

nice to see you that you awarded point to yourself

Regards,