Showing results for 
Search instead for 
Did you mean: 

SAPSQL_ARRAY_INSERT_DUPREC - When saving an instance profile from RZ10

Former Member
0 Kudos

Dear SDN,

I have an issue when I try to save my instance profile from RZ10.

I always get a dump (ST22) :




The ABAP/4 Open SQL array insert results in duplicate database records.

An exception occurred that is explained in detail below.

The exception, which is assigned to class 'CX_SY_OPEN_SQL_DB',

was not caught in procedure "PFL_WRITE_PROFILE_TO_DB" "(FUNCTION)",

nor was it propagated by a RAISING clause.

Since the caller of the procedure could not have anticipated that the

exception would occur, the current program is terminated.

The reason for the exception is:

If you use an ABAP/4 Open SQL array insert to insert a record in

the database and that record already exists with the same key,

this results in a termination.

(With an ABAP/4 Open SQL single record insert in the same error

situation, processing does not terminate, but SY-SUBRC is set to 4.)


In RZ10, I only have version 0001 of my instance profile (SID_DVEBMGSxxx_Hostname)

But in table tpfet, I have 2 version of the same profile.

I have already tried to remove the profile from RZ10 and try to re-import it.



SAP NetWeaver Admin

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Dear SDN,

I have finally found the reason of the issue.

1. In RZ10, I only have version 0001 of my instance profile xx_DVEBMGSxx_hostname.

2. But in tabel TPFET, in the db, I also had version 0002 of the instance profile xx_DVEBMGSxx_hostname.

This is the reason of SAPSQL_ARRAY_INSERT_DUPREC.

Best regards

SAP NetWeaverAdmin

Former Member
0 Kudos

Hi Even i had the same issue when the system is cloned/system refreshed from production.

you need to goto se14 and TPFET tabel then select the option to delete the data and activate and adjust the database table. which will eventually delete the prod entries from the table.

then you will be able to import the profiles in RZ10.



Former Member
0 Kudos

1. Check for duplicate profile or remove older profiles @ OS Level.

2. Try to import the profiles again in RZ10 - try again.