Showing results for 
Search instead for 
Did you mean: 

SAPRouter problem

Former Member
0 Kudos


I'm trying to start my SapRouter with the command :

<i>saprouter -r -R c:\saprouter\saprouttab</i>

But it sounds that doesn't work.

Here is the error message :

<i>trcfile dev_rout

no logging active

      • ERROR => invalid lines in c:\saprouter\saprouttab, see dev_rout [nixxrout.c 2973]</i>

This server is on a DMZ and SAPServers are on internal network but everything on the firewall was checked out.

Hereunder the content of the saprouttab file :

<i>P LUEXT007 sapserv3 3299

P sapserv3 LUEXT007 3200

P LUEXT007 sapserv3 3399

P sapserv3 LUEXT007 3300

P ludbs010 sapserv3 3299

P ludbs019 sapserv3 3299

P ludbs020 sapserv3 3299

P ludbs013 sapserv3 3299

P ludbs026 sapserv3 3299

P ludbs027 sapserv3 3299

P ludbs028 sapserv3 3299

P ludbs031 sapserv3 3299

P ludbs032 sapserv3 3299

P ludbstest9i sapserv3 3299

P sapserv3 3299

P ludbs010 sapserv3 3399

P ludbs019 sapserv3 3399

P ludbs020 sapserv3 3399

P ludbs013 sapserv3 3399

P ludbs026 sapserv3 3399

P ludbs027 sapserv3 3399

P ludbs028 sapserv3 3399

P ludbs031 sapserv3 3399

P ludbs032 sapserv3 3399

P ludbstest9i sapserv3 3399

P ludbs010 sapserv3 3300

P ludbs019 sapserv3 3300

P ludbs020 sapserv3 3300

P ludbs013 sapserv3 3300

P ludbs026 sapserv3 3300

P ludbs027 sapserv3 3300

P ludbs028 sapserv3 3300

P ludbs031 sapserv3 3300

P ludbs032 sapserv3 3300

P ludbstest9i sapserv3 3300

P sapserv3 LUEXT007 3299

P sapserv3 ludbs010 3200

P sapserv3 ludbs019 3200

P sapserv3 ludbs020 3200

P sapserv3 ludbs013 3200

P sapserv3 ludbs026 3200

P sapserv3 ludbs027 3200

P sapserv3 ludbs028 3200

P sapserv3 ludbs031 3200

P sapserv3 ludbs032 3200

P sapserv3 ludbstest9i 3200

P sapserv3 ludbs010 3299

P sapserv3 ludbs019 3299

P sapserv3 ludbs020 3299

P sapserv3 ludbs013 3299

P sapserv3 ludbs026 3299

P sapserv3 ludbs027 3299

P sapserv3 ludbs028 3299

P sapserv3 ludbs031 3299

P sapserv3 ludbs032 3299

P sapserv3 ludbstest9i 3299

P sapserv3 ludbs010 3300

P sapserv3 ludbs019 3300

P sapserv3 ludbs020 3300

P sapserv3 ludbs013 3300

P sapserv3 ludbs026 3300

P sapserv3 ludbs027 3300

P sapserv3 ludbs028 3300

P sapserv3 ludbs031 3300

P sapserv3 ludbs032 3300

P sapserv3 ludbstest9i 3300

p sapserv3 ludbs010 3399

p sapserv3 ludbs019 3399

P sapserv3 ludbs020 3399

P sapserv3 ludbs013 3399

P sapserv3 ludbs026 3399

P sapserv3 ludbs027 3399

P sapserv3 ludbs028 3399

P sapserv3 ludbs031 3399

P sapserv3 ludbs032 3399

P sapserv3 ludbstest9i 3399

p * * *

p * * *

p * * *</i>

Thank you in advance,


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Alex,

Steps to configure SAProuter:

1.Downloaded SAP Router and SAP Cryptographic Software.

2.Extracted the files using SAPCAR and placed them under saprouter folder usr\sap\saprouter

3.Applying for SAP Router Certificate

4.Generating PSE file

5.Copied content of certreq file

6.Requesting the certificate

7.Installed certificate

8.Added Credentials

9.Checked for Correct Installation

10.Maintained the Environment Variable SNC_LIB


11.Maintained saprouttab table

12.Installing SAP Router



Reward Points Welcome!

Former Member
0 Kudos

Hi Rajesh,

I've check the config of our saprouter but I think there's no certificate and no need to use set the environnment variable SNC_LIB.

Could you confirm it ?


Former Member
0 Kudos

Hi Alexandre,

If you want to use the SNC then definitely you need to have the

secure certificate. First you have to generate it using sapgenpse

it will create a file called cert in the folder saprouter\ntintel

prior configure the path of SNC_LIB and Also SECUDIR



set this variables. Then go to service market place and go to TCS

Request for the certificate then copy that certificate and paste in a txt

file with the name srcert.then import that certificate into saprouter.

Maintain routetab and then start the router.

Reward points if helpful.



Answers (6)

Answers (6)

Former Member
0 Kudos

Thank you all for you answer.

Issue was due to pb on leased line and is now solved.

Former Member
0 Kudos

Are you allowing DNS requests to go in and out of this server? Or have you tried pinging some of the domain names you have entered in the saprouttab file?

Just thought I'd see if you checked the basics.

J. Haynes

Denver, CO

Former Member
0 Kudos

Hi all,

I tried this command <i>saprouter -r -G routerlog -S 3299 -K "p:CN=<sid>, OU=<number>, OU=SAProuter, O=sap, C=DE"</i> and apply Notes #734095. But the problem is still the same.

When i want to start saprouter the command prompt stay to this status :

<i>trcfile dev_rout

no logging active</i>

Does anyone have an idea ?

Thank you,


Former Member
0 Kudos

Hi Alexandre,

If you don't see any errors in the console, it means the SAPRouter has started successfully. Should the connection still not work, check the log file - in your case the routerlog.

There should also be a trace file written out. In case you have errors, could you post them here?



Former Member
0 Kudos

Hi Alexandre,

Go to this path c:\usr\sap\saprouter

and execute this command

saprouter -r -G routerlog -S 3299 -K "p:CN=<sid>, OU=<number>, OU=SAProuter, O=sap, C=DE"

This command should work.

Reward points if helpful.



Former Member
0 Kudos

Hi Alexandre,

Try putting "P" for last three entry instead of "p".

- Pinkle

Message was edited by:

Pinkle Naik

Former Member
0 Kudos

HI Alenx..

Try only saprouter -r c:\saprouter\saprouttab

I think that is enough. It should start and look at note : 734095.