Showing results for 
Search instead for 
Did you mean: 

sapinst.exe crashes on Windows 7 (ver. 6.1)

Former Member
0 Kudos


I am trying to install Netweaver CE 7.11 on Windows 7 64-bit. Yes, I know it is not supported. But still, I would like to ask right about the reason sapinst.exe crashes.

So, sapinst.exe can be launched in Win 7 native mode, but it is not compliant with OS compatibility. So I am trying to launch it in Vista mode. But sapinst.exe crashes with error log like this (sorry for flood, but see below).

At the same time sapinst.exe launches in Win 7 native mode + 32-bit sapinst.exe launches in Vista mode. Only 64-bit sapinst crashes in Vista mode. I suspect this is related just to JVM and near that, and may be solved. Please, advise, if someone has more expertise than me or experience with such or similar situations.

Thank you.




  1. An unexpected error has been detected by SAP Java Virtual Machine:


  1. EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000076def2d5, pid=2852, tid=1484


  1. Java VM: SAP Java 64-Bit Server VM (5.1.000 Feb 13 2007 23:26:13 - 01_REL - optU - bas2:69696 (mixed mode))

  2. Problematic frame:

  3. C ntdll::RtlCaptureContext+0x85 (0x4f2d5)



T H R E A D -

Current thread (0x0000000000a4f3c0): JavaThread "main" [_thread_in_Java, id=1484]

siginfo: ExceptionCode=0xc0000005, reading address 0xffffffffffffffff



P R O C E S S -

Java Threads: ( => current thread )

0x00000000202dc930 JavaThread "HttpServer" [_thread_in_native, id=4028]

0x00000000202dc580 JavaThread "HttpWorker" [_thread_blocked, id=3948]

0x00000000202dc1d0 JavaThread "HttpWorker" [_thread_blocked, id=6148]

0x00000000202dba70 JavaThread "HttpWorker" [_thread_blocked, id=2116]

0x00000000202ddf50 JavaThread "AlarmClock" [_thread_blocked, id=1000]

0x00000000202db310 JavaThread "AWT-EventQueue-0" [_thread_blocked, id=7144]

0x0000000020143230 JavaThread "Java2D Disposer" daemon [_thread_blocked, id=5636]

0x000000001f37f8c0 JavaThread "Image Fetcher 0" daemon [_thread_blocked, id=6060]

0x000000001f37f1b0 JavaThread "AWT-Windows" daemon [_thread_in_native, id=316]

0x0000000020010bc0 JavaThread "AWT-Shutdown" [_thread_blocked, id=1020]

0x000000001f027180 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=5528]

0x000000001f026880 JavaThread "CompilerThread1" daemon [_thread_blocked, id=5116]

0x000000001f01fa70 JavaThread "CompilerThread0" daemon [_thread_blocked, id=5336]

0x000000001f01f060 JavaThread "AdapterThread" daemon [_thread_blocked, id=6240]

0x000000001f01e2f0 JavaThread "Control Handler" daemon [_thread_blocked, id=6532]

0x000000001f01da00 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=6072]

0x000000001f018af0 JavaThread "JDWP Event Helper Thread" daemon [_thread_blocked, id=6636]

0x000000001f014d10 JavaThread "JDWP Transport Listener: dt_socket" daemon [_thread_blocked, id=4964]

0x000000001e805070 JavaThread "Finalizer" daemon [_thread_blocked, id=2964]

0x000000001e8030f0 JavaThread "Reference Handler" daemon [_thread_blocked, id=324]

=>0x0000000000a4f3c0 JavaThread "main" [_thread_in_Java, id=1484]


VM Arguments:

jvm_args: -Xmx256M -Dsun.java2d.noddraw=true -Dsap.env.var.javahome=SAPINST_JRE_HOME -agentlib:jdwp=transport=dt_socket,server=y,address=8000-8100,suspend=n

classpath: C:\Users\user1\AppData\Local\Temp\sapinst_exe.5632.1284041309\jar\instgui.jar

java_command: SDTGui instwizard host=localhost port=21201 -nolock

Launcher Type: SAP_STANDARD

Environment Variables:

PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Microsoft Application Virtualization Client;C:\Program Files\ThinkPad\Bluetooth Software\;C:\Program Files\ThinkPad\Bluetooth Software\syswow64;



PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 37 Stepping 2, GenuineIntel

current directory: C:\Users\user1\Desktop\CE711_01_IM_WIN_X86_64_ADA


S Y S T E M -

OS: Windows Vista Build 6000

CPU:total 4 em64t ht

Memory: 4k page, physical 4050608k(1810264k free), swap 8406516k(5986780k free)

vm_info: SAP Java 64-Bit Server VM (5.1.000) for windows-amd64, built on Feb 13 2007 23:26:13 by unknown with MS VC++ 8.0

hostname: IEVN60202577A

Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos
Yes, I know it is not supported

Well, I know that's not what you want to hear, but this is the truth, after 1 day, nobody tried to help you becasue you are on an unsupported OS for that product.

I do not know why you want to keep on trying an unsupported combination.

Former Member
0 Kudos

Hi Eric,

thank you for your attention. As you see, I am not asking why NW does not work on unsupported platform I am wondering simply why exe file crashes in Vista mode.

Anyway, you may be right, no one will try deal with this besides me.

Thank you.



Answers (1)

Answers (1)

Former Member
0 Kudos

Also, I noticed that possibly JVM crashes in ntdll.dll. Here are some libs, from the errorlog:

0x0000000000400000 - 0x0000000000415000 C:\Users\i057882\AppData\Local\Temp\sapinst_exe.5528.1284043695\jre\bin\java.exe

0x0000000076da0000 - 0x0000000076f4b000 C:\Windows\SYSTEM32\ntdll.dll

0x0000000076c80000 - 0x0000000076d9f000 C:\Windows\system32\kernel32.dll

0x000007fefcdb0000 - 0x000007fefce1b000 C:\Windows\system32\KERNELBASE.dll

0x000007fefecb0000 - 0x000007fefed8b000 C:\Windows\system32\ADVAPI32.dll

0x000007fefe980000 - 0x000007fefea1f000 C:\Windows\system32\msvcrt.dll

Exception always occurs here: EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc= 0x0000000076def2d5

So I assume ntdll.dll is the place where crash happens. Am I right? And what could it mean?



Edited by: Anton Shabinskyi on Sep 9, 2010 5:59 PM