cancel
Showing results for 
Search instead for 
Did you mean: 

Sap WAS 6.20 or 6.40

Former Member
0 Kudos
216

Hi,

I am reading TBIT40, one text paragraph with external systems that a direct system connection using proxies and without additional adapters is supported for SAP systems that are based on SAP Web Application Server 6.20 or higher, but in a graph, it indicate 6.40, so I am just wondering:

1. It is 6.20 or 6.40 no need adapters?

2. If it is 6.20 or higher, which means if the system just 6.20, then it won't need adapter?

Thanks for your input.

Accepted Solutions (1)

Accepted Solutions (1)

Shabarish_Nair
Active Contributor
0 Kudos

if you are talking about proxies, they are supported only from WAS 6.4 and above.

for others, you can still use IDoc and RFC based communications

Former Member
0 Kudos

Thank you Shabarish.

This is a quote I got from TBIT40, can I say the statement is not accurate?

"There are no additional adapters needed, when the Integration Server connects to a new mySAP solution which is based on the SAP Web Application Server 6.20, as the components of these solutions carry themselves a “small” Integration Engine – those systems can directly interact and communicate with the Integration Server to exchange XML messages."

Shabarish_Nair
Active Contributor
0 Kudos

if this is in the context of proxies, i think it would be wrong - http://help.sap.com/saphelp_nw04/helpdata/en/02/265c3cf311070ae10000000a114084/content.htm

nabendu_sen
Active Contributor
0 Kudos

Hi Blue,

There was a confusion between WAS 6.2 and WAS 6.4. But I think ABAP Proxy can be used with WAS 6.4 or higher. Please find the below link from SAP.

http://help.sap.com/saphelp_nw2004s/helpdata/en/48/d5a1fe5f317a4e8e35801ed2c88246/frameset.htm

Prerequisites

You can only use the program model described here for systems that are based on SAP Web AS 6.40 or higher.

Former Member
0 Kudos

Thank you Nabendu and Shabarish

I will check the links

baskar_gopalakrishnan2
Active Contributor
0 Kudos

This TBIT 40 document refers the communication between local integration engine (SAP system which has WAS 6.4 ) and central integration engine (SAP PI) using proxy communication (adapter less) between them. You need to have some add on for communication if the sap system(older) is 6,2  lower like some   connectors or so.

Basically if you use client proxy you don't need adapter (as you know) . The main reason is local integration engine of sap system can reach the central integration engine as if they are in the same stack and does not need message protocol (proxy) because both the integration engine uses PI soap as the message protocol for the processing.  Hope this helps. Whereas server proxy requires adapter  to identify the client of the sap system.

Former Member
0 Kudos

Thank you very much Baskar.

So you confirm as well if a sap system based WAS 6.4 or higher, and it communicate with other applications through XI, then it doesn't need adapter, whereas if it was based on 6.2, then it won't need adapters neither, but some add on, right?

baskar_gopalakrishnan2
Active Contributor
0 Kudos

Yes. That is correct.

Former Member
0 Kudos

Thank you Baskar.

Answers (0)