cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Transaction iView Restriction

Former Member
0 Kudos

Hi Experts,

I have created SAP Transaction iView Successfully. In this view i will do any other transaction(like create Sales order, purchase order )

Is it Possible to restrict to do any transaction? If Possible How to do that?

Regards,

Manivannan P

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Manivannan,

you need to hide the tool bar so that user cannot enter any transaction.

check this thread

https://forums.sdn.sap.com/click.jspa?searchID=25693176&messageID=7268401

Thanks

Bala Duvvuri

Former Member
0 Kudos

Hi bala,

I gone through the link. The link shows


in your ITS tcode under the GUI configuration use the following settings:

~WEBGUI =1
~RECORD=1
~SINGLETRANSACTION=1
~TRANSACTION= " "
~WEBGUI_SIMPLE_TOOLBAR= 160

where will i go to give these settings

Regards,

Manivannan P

Former Member
0 Kudos

Manivannan,

go to tcode SICF and check this

Go to the ITS service /sap/bc/gui/sap/its/webgui

Open it to modify click on GUI Configuration.

Change the value of the parameter ~ WEBGUI_SIMPLE_TOOLBAR to 32 from 0.

Thanks

Bala Duvvuri

Former Member
0 Kudos

Hi Bala,

Thanks for your reply. I have done that. Now User unable to go another transaction. I have one more question?

I need Some users wants to do any tranaction? some users wants to do only one transaction?

Is it possible to do in portal?

Regards,

Manivannan P

Former Member
0 Kudos

That's what I meant about annoying part of the user community!

You need to have two iViews - one that passes the parameter to hide the command bar and another that allows the command bar to be visible. To do this you need to remove the setting in SICF and pass as a parameter in the iView.... Then you need to find a way for the experienced users not to tell the other users how to bypass your setup...

Former Member
0 Kudos

Hi michel,

Thanks for your reply.

How to hide the command bar?

Regards,

Manivannan P

Former Member
0 Kudos

If you make a URL iView, then starting webgui with ~NOHEADEROKCODE=1 hides the okcode and with a value of 0 the okcode field is visible.

Former Member
0 Kudos

Hi michel,

I gave URL iview in the following way

http://<server name>:<port>/sap/bc/gui/sap/its/webgui/~NOHEADEROKCODE=1

after previewing the iview it shows the ok field. is this format is correct? if wrong correct me?

Regards,

Manivannan P

Former Member
0 Kudos

You need a ? before the ~ character...

Former Member
0 Kudos

Hi Michel ,

Its Working fine. thanks

Regards,

Manivannan P

Answers (1)

Answers (1)

Former Member
0 Kudos

Why do you want to hide the command area? It is not a security risk to have it there and some users will find it convenient. Removing it just annoys a large part of the user population!