Showing results for 
Search instead for 
Did you mean: 

SAP Trail Datasphere Analytical models are not appearing in Trail SAP Analytics Cloud - Live Connect


Hello Experts,

I have created SAP trail Datasphere and Trail SAP Analytics Cloud accounts.

Datasphere: In data builder, i have created a table and uploaded the data from CSV file. On top of this table, i have created a new graphical view and enabled Expose for Consumption. Then , i have created new Analytic model as a last step.

SAP Analytics Cloud : In SAC, I created a Live connection to the Datasphere and it was successful. Then, when i try to create a story and consume the analytical model using this live connection, i don't see this model appearing and space is empty.

Can you any help/ or suggest what is the issue?.





View Entire Topic


did you check what development tools are saying ? (error Code in browser ect)

Sadly the error message handling in cloud tools overall is pretty bad, you have to check the Networktab of the Development tools of the Browser to get more information about the error that occurs.



0 Kudos

Hi Julian,

Thanks for your reply.

I have checked the error but not able to actually get the cause of the issue.

message: "Bad request while calling RepositorySearch. Query: /repository/search/$all?&$select=deployment_name,business_name,creator_user_name,deployment_business_type,id,space_description,space_name&whyfound=true&$count=true&$apply=filter('SCOPE:SEARCH_DESIGN ((kind:EQ(S):\"deployedObject\" AND (deployment_business_type:EQ(S):\"DWC_CUBE\" OR deployment_business_type:EQ(S):\"DWC_FACT\") AND exposed_for_consumption_id:EQ(S):\"true\" AND space_name:EQ(S):\"GE098144\")) (deployment_name business_name creator_user_name):()'))&$orderby=deployment_name ASC&$top=60&$skip=0"




So what you pasted there is the Odata (request) URL from SAC to DSP, that should deliever the Result back to SAC.

However this Request failes with Error Code 400. (200 would be good)

4xx Http Error code means client problems (so you 😉 )

Did you try different Browers ? Maybe you have plugin or extenions that is causing Problems.

0 Kudos

Yes, Julian I have tried other browsers and incognito mode as well, but still no luck.

Any workaround suggestions are highly appreciated.

0 Kudos

my tip: Try to isolate the problem.
Is the problem only occuring in that space for that AM or is it ocurring in general, so for all AM of all Spaces ? 
Do you have mulitple DSP connected to the SAC Tenant ? If yes, is the Problem also for other DSP Tenants existing ? 
Did you try to simply copy the AM and save it under a new Name?