cancel
Showing results for 
Search instead for 
Did you mean: 

SAP PO 7.5 - SFTP Receiver adapter issue in test environment

Bhargavakrishna
Active Contributor
0 Kudos

Dear Experts,

We are on SAP PO 7.5 SP13. we are facing the below strange issues with SFTP receiver adapter very frequently.

These issue is not limited to one particular to SFTP server or Channel. This issue affecting all SFTP communications on our test environment. Please find the below list of issue that we face in our application more frequently.

  • Send Failed : com.kcraft.jsch.JschException: Connection to SFTP server failed. The login credentials provided are incorrect.
  • Send Failed :java.lang.Exception: directory does not exist.
  • Send Failed : 2:pwd failed.
  • Send Failed : Could not obtain resource within timeout

After restarting the channel it works again and few messages will get processed and then the errors appear again.

We have compared the channel configurations in Test and Production environments, but we couldn't find any differences.

we have activated the "connection.mode.permanent" parameter, but still the issue persist.

Request you all to provide suggestions to fix this issue.

Thanks

Bhargava Krishna

Accepted Solutions (0)

Answers (3)

Answers (3)

JaySchwendemann
Active Contributor
0 Kudos

You may wanna have a look at this https://answers.sap.com/questions/178869/connection-to-sftp-server-failed---the-login-crede.html and also the linked note within: https://launchpad.support.sap.com/#/notes/2344454

  • Maybe there's a mismatch in sFTP Adapter Versions between Test and Prod
  • Are the receiver channels all pointing to a special sFTP server or different servers? I'm asking because it may be that the sFTP Server does not support the correct auth scheme
  • Did you try XPI inspector?
  • I would think that permanent mode is more counterproductive in this situation

Cheers

Jens

Bhargavakrishna
Active Contributor
0 Kudos

This is happening with receiver channels only.

We set the below parameters in the communication channel, but no luck. The issue still persists.

  1. Additional Parameters: connection.mode.permanent is set to “True”
  2. Additional Parameter 'check.resource.int' with value 'true'.

Finally, Scheduled the SFTP channels to automatically stop/start every 1 hr. So that the active connections will be refreshed.

We have implemented this and continuously monitored the channels. No issues reported so far.

Regards

Bhargava Krishna

JaySchwendemann
Active Contributor
0 Kudos

Does this only affect receiver channels or also sender channels? If this happens regularly, you may want to have an XPI Inspector trace (Example 50) running to hopefully better see what's what

Bhargavakrishna
Active Contributor
0 Kudos

This isssue is with receiver channels only.