Showing results for 
Search instead for 
Did you mean: 

sap.m.Input with custom valueHelpRequest doesn't work

0 Kudos

I used sapui5 version 1.54.3 to render input fields with a custom HelpRequest value and it worked perfectly.

I tried to upgrade to version 1.80.0 and my field just stopped working.

When making this version change I was forced to add this method 'this.addEndIcon ("sap-icon: // value-help")' because it was causing an error on the screen and it didn't even load. And in version 1.54.3 it was not necessary.

The problem is that adding this icon manually to the help field and it didn't work anymore. I did the element inspection and the method to be called was attached correctly.

Executing this: sap.ui.getCore (). ById ("__ company1"). FireValueHelpRequest () the method that has been defined is called. However, if I click on the helper button nothing happens.

Can anyone help me on this issue?

openDialog: function() {

renderer: {
        render: function(oRm, oControl) {

            sap.m.InputRenderer.render(oRm, oControl);

Accepted Solutions (0)

Answers (0)