cancel
Showing results for 
Search instead for 
Did you mean: 

SAP IDM 8.0 PATCH2 ERROR : util-functions sqlplus command not found

Former Member
0 Kudos
138

Hi experts,

We just tried to apply the Patch2 for IDM8.0 and when i start with the databse after changing as always the include file etc...., I launch the mxmc-update.sh i have this message error  " ./util-functionsh line 76 sqlplus: command not found "


We did not changed any configuration after the first installation of the IDM 8.0 so the PATH and environment variable and the JDBC are fine.


We use Oracle as Database/Linux


any one have any ideas about this problem ?



BR El-Mehdi


Accepted Solutions (0)

Answers (2)

Answers (2)

former_member2987
Active Contributor
0 Kudos

Hi Elmehdi,

When Oracle and Linux are involved, I always recommend working with your sysadmins and dbas.  It's just easier that way. 

Matt

Former Member
0 Kudos

Hi Matt,

The problem's when i tried to launch the script to update my DB "mxmc-update" it demands my DID_oper password so when i gave the password i got this error for !

i check the sqlplus command i can connect to my DB with the Sysadmin and also my DB users

BR, El-Mehdi

rondv
Advisor
Advisor
0 Kudos

Maybe it could be a script format issue.

You're on Linux. Check the files in the database/<db type> directory to see if there are any CRLFs in there.

You can do this with  "file *" when in the directory. If any have CRLFs, convert them with dos2unix <filename> and then rerun.

If that isn't it, check your environment to see if the Oracle environment (.cshrc or other scripts that might have to be run to set up the account corrrectly) is set up right. Run sqlplus with the same user before you run the IDM scripts to see if that works and fix as needed.

If it's something else then hopefully either your Oracle DBA team or the rest of the community can guide you along.

Message was edited by: Ronald De Vries

Former Member
0 Kudos

Hi Ronald,

Thank you for your answer,

I checked the script format it was fine, i also tried to launch the intial IDM 8.0 script to update my  DB " i used to update my Database the first " so i got the same error !!!


BR, El-Mehdi