cancel
Showing results for 
Search instead for 
Did you mean: 

SAP IDES license error

pole_li
Active Participant
0 Kudos
952

Hi,

Our ECC6 Ehp3 IDES system got license check error and we can not log in any client.

In command line , I have run license check, the result was OK:


C:\Documents and Settings\ideadm.FWSAP>saplicense -test pf=/usr/sap/IDE/SYS/prof
ile/DEFAULT.PFL
Protocol saplicense test:
   *** Read sapsytem name
       ok, sapsytem name = IDE
   *** Read message server host
       ok, host = fwsap
   *** Read message server service port
       ok, service port = sapmsIDE
   *** Connect to message server
       ok, connect done
   *** Read hardware key from message server
       ok, got hardware key
   *** Detach from message server
       ok, detached
   *** Check hardware key
       ok, hardware key = Q0399867250
   *** Connect to database
       ok, connected
   *** Check license
       ok, check done
   *** Disconnect database
       ok, database disconnected
test result: license test ok

I have delete SAP* user in USR02 table and set login/no_automatic_user_sapstar = 0 in default.pfl

But when I try to login with SAP*/PASS , it promt error "Name or password incorrect"

Check in Syslog, there was error:SAP-Basis System: Msg server hardware ID missing (HWID_PENDING)

Anyone has idea about this problem? thanks a lot!

Regards,

Pole

View Entire Topic
rupali_karbhari3
Active Contributor
0 Kudos

Hi Pole,

Can you please check if your SAP instance is running via MMC i.g. message server , dialog instance, dispatcher etc,

It seems there is connection issue

Regards,

pole_li
Active Participant
0 Kudos

Hi Rupali&Venky,

disp+work.exe running but not connected to message server(in yellow color), but in SAPGUI, it can connect to the IDES system,

if we login with SAP* user, it promt wrong user or password error, if login with normal user, it promt "error in license check".

I have checked the trace log,

in dev_w0 file, error message like:


M  Modeinfo for User T0/M0
M  
M    tm state = 2
M    uid = 1
M    term type = 0x2
M    display = 0x0
M    cpic_no = 0
M    cpic_idx = -1
M    usr = >SAPSYS      <
M    terminal = >                    <
M    client = >000<
M    conversation_ID = >        <
M    appc_tm_conv_idx = -1
M    its_plugin = NO
M    allowCreateMode = YES
M    blockSoftCanel = NO
M    session_id = >BC3E58E135F5F1528056000D60ECC012<
M    ext_session_id = >BC3E58E135F5F1528056000D60ECC012<
M    imode = 2
M    mode state = 0x42
M    mode clean_state = 1
M    task_type = ZTTAAUTOABAP
M    lastThFc = THFCAUTOABAP
M    lastAction = TH_IACT_NO_ACTION
M    th_errno = 0
M    rollout_reason = 0
M    last_rollout_level = 7
M    async_receives = 0
M    cpic_receive = 0
M    em handle = 0
M    roll state = 2
M    abap state = 2
M    em state = 3
M    eg state = 1
M    spa state = 3
M    enq state = 0
M    softcancel = 0
M    next hook = T-1/U-1/M255
M    master hook = T-1/U-1/M255
M    slave hook = T-1/U-1/M255
M    debug_tid = 255
M    debug_mode = 0
M    mode type = 0x1
M    debug = 0
M    msg_count = 6181
M    tcode = >                    <
M    client conversation_ID = >        <
M    server conversation_ID = >        <
M    lock = 0
M    max enq infos = 9
M    act enq infos = 2
M    em_hyper_hdl = 54E26390
M    plugin_info = NULL
M    act_plugin_hdl = -1
M    act_plugin_no  = 0
M    max_plugin_no  = 0
M    async_receives = 0
M    vm = no VM
M  
{color:red}
M  *** ERROR => ThMBufFullRead: ThOpcodeToMsg [thxxmbuf.c   225]
M  *** ERROR => ThMBufGet: ThMBufFullRead [thxxmbuf.c   183]
M  *** ERROR => ThCheckReqInfo: message send/receive failed [thxxhead.c   17143]
{color}

in dev.disp error message:


Wed Feb 15 12:31:48 2012
rdisp/http_min_wait_dia_wp : 1 -> 1
***LOG CPS=> DpLoopInit, ICU ( 3.0 3.0 4.0.1) [dpxxdisp.c   1629]
***LOG Q0F=> DpLoopInit, nomstry () [dpxxdisp.c   1716]
{color:red}
*** ERROR => Connection to Message Server failed - check installation [dpxxdisp.c   1717]
{color}
CCMS: AlInitGlobals : alert/use_sema_lock = TRUE.

Wed Feb 15 12:32:08 2012
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndAdmin () [dpxxdisp.c   4735]

Wed Feb 15 12:32:09 2012
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]

Wed Feb 15 12:32:10 2012
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndAdmin () [dpxxdisp.c   4735]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndAdmin () [dpxxdisp.c   4735]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]
*** ERROR => MsISnd2: not_attached [msxxi.c      1321]
***LOG Q0N=> DpRqNoWpHandle, MsSndName () [dpxxdisp.c   4651]

dev.ms message:


[Thr 4576] ***LOG Q01=> MsSInit, MSStart (Msg Server 1 6500) [msxxserv.c   1824]
[Thr 4576] ***LOG S0J=> MsInitAclInfo, fopen failed ( 22) [msxxacl.c    279]
[Thr 4576] ***LOG S0K=> MsInitAclInfo, fopen failed (\\fwsap.test.com\sapmnt\I) [msxxacl.c    284]
{color:red}
[Thr 4576] *** ERROR => MsInitAclInfo: fopen("\\fwsap.test.com\sapmnt\IDE\SYS\global\ms_acl_info.DAT","r") failed (No error) [msxxacl.c    289]
{color}
[Thr 4576] MsGetOwnIpAddr: my host addresses are :
[Thr 4576]   1 : [10.1.8.21] fwsap (HOSTNAME)
[Thr 4576]   2 : [127.0.0.1] fwsap (LOCALHOST)
[Thr 4576]   3 : [192.168.100.35] fwsap (NILIST)
[Thr 4576] MsHttpInit: full qualified hostname = fwsap.test.com
[Thr 4576] HTTP logging is switch off
[Thr 4576] set HTTP state to LISTEN
[Thr 4576] MsHttpOwnDomain: own domain[1] = test.com
[Thr 4576] ms/icf_info_server : deleted
[Thr 4576] *** I listen to port sapmsIDE (3602) ***
[Thr 4576] *** HTTP port 8102 state LISTEN ***

Regards,

Pole