cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Data Services doesn't continue after processing JOB.

former_member460511
Discoverer
0 Kudos

Hi Team,

As up to upgrade to 4.2sp8, from current version 4.0 , I have successfully installed 4.2 SP8 ( IPS - 4.2 SP 3 and Data Services- 4.2 sp8) On AIX OS.
OS Version - sap@pidf307> uname -a
AIX pidf307 1 6 00C8E97F4C00

After successful installation I validated services and upgraded contents using Repository MAnager.


sap@pidf307> al_jobserver -v
SAP Data Services Job Server Version = 14.2.8.1354
sap@pidf307> al_engine -v
SAP Data Services Engine Version 14.2.8.1354
sap@pidf307> AL_JobService -v
SAP Data Services Job Service Version = 14.2.8.1354

But while executing DataService Job it doesn't pass through processing stage.What might be issue ?Empty Monitor and error log. Below are trace of JOB

sap@pidf307> cat trace_09_06_2017_21_25_15_33__d0370ec6_4431_49d2_a541_f6840594dee1.txt
(14.2) 09-06-17 21:25:15 (25166202:0001) JOB: The initial environment locale <eng_us.utf-8> has been coerced to <Unicode (UTF-16)> ().
(14.2) 09-06-17 21:25:16 (25166202:0001) JOB: Reading job <d0370ec6_4431_49d2_a541_f6840594dee1> from the repository; Server version is <14.2.8.1354>; Repository version is
<14.2.8.0000>.
(14.2) 09-06-17 21:25:16 (25166202:0001) JOB: Current directory of job <d0370ec6_4431_49d2_a541_f6840594dee1> is </appl2/EIA/BO/sap/42sp8/dataservices/bin>.
(14.2) 09-06-17 21:25:16 (25166202:0001) JOB: Starting job on job server host <pidf307.pedc.sbc.com>, port <3500>.
(14.2) 09-06-17 21:25:17 (25166202:0001) JOB: Job <bj_PostalCertification_Extra10> of runid <2017090621251625166202001> is initiated by user <sap>.
(14.2) 09-06-17 21:25:17 (25166202:0001) JOB: Processing job <bj_PostalCertification_Extra10>.

Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Hi Srikanth,

Have you tried to verify the version detail both from the Designer and Console?Is it reflected with new version?

Because we were also facing same issue with empty logs we tried repairing the installtaion and it worked for us.

Still if you have the same issue, Pleas give a try for the repair of Data services it may resolve your issue.

Thanks,

Sagar T

former_member460511
Discoverer
0 Kudos

Hi Chaitanya,

I checked on DB and we see no locks. We tried executing some basic jobs everything works except Address cleanse jobs. For Address cleanse it stops at processing stage. When I ran trace here's where it stops

19923426 1 TRAN 9/12/2017 12:58:51 PM Loaded <liburacverifieru.so> is in the path: </opt/app/sap/42sp8/dataservices/bin>.

Former Member
0 Kudos

Hi Srikanth,

This step will actually get latest code of job triggered from the AL_Version table of the repository data base . So this can happen if any locks has been created on this table or also check weather any session is being created in DB for the same or not .

we have faced the similar issue and by clearing locks on this Al_version table has solved our issue .

As this is occurred immediately after upgrade you may need to check other way as well .

Thanks and regards

Chaitanya