cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Cloud SDK : AdvanceListPanel Default blank Row Display end of all record

Former Member
0 Kudos

Hi Experts,

I have created the embed component using custom object and display under the Account_TI screen.

That embed component working fine in Account_TI screen.

Under embed component i have add 1 AdvanceListPanel and Display the data based on the Account ID respectively.

The above screen is Account_TI screen with embed component and under the Contract_Product tab we can able to see the record under th AdvanceListPanel but at the end of every time  display the blank row.

I want to remove that blank row then how to achieve this using SDK or any configuration require under the embed component or any ABSL code to remove the blank row under the AdvanceListPanel.

Please help me to resolve this issue.

Many Thanks,

Mithun

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Mithun,

Try to set the "TableRowCreator" property to false and let me know the outcome.

Thanks.

Best regards,

Fernando Giroleti

SAP Cloud Service Center AMEA

Former Member
0 Kudos

HI Femando,

Thanks for your reply.

I have change the property TableRowCreator to false and its working.

Do you know how to add filter in the advance list panel in embed component?

Many Thanks,

Mithun

Former Member
0 Kudos

Hi Mithun,

I suggest you to create a separate thread for your new inquiry.

In case any developer had the same question in the future, would be easier to find the solution.

Thanks.

Fernando

Former Member
0 Kudos

Sure Fernando,

I will create new discussion.

Many Thanks,

Mithun

Answers (1)

Answers (1)

0 Kudos

Hi Fernando,

I am also facing the same issue. I have created two embedded component using two custom BO under Service Ticket Screen.

Under both Embedded Components, I have created two AdvancedListPane.

In First EC, I have used one Button "Assign" under AdvancedListPane to save data (create instance) into Another EC under AdvancedListPane.

On every Click, Data is getting saved into Another BO but bydefault a blank row is getting generated in first BO. I have set "TableRowCreator" to false, but its not working for me.

Please help me to resolve this issue.


Thanks,

Savita