cancel
Showing results for 
Search instead for 
Did you mean: 

SAP CLOUD CONNECTOR Password

ranjit_rao
Participant
0 Kudos

Hi,

I have changed the initial password of SAP Cloud Connector and have forgot the new password. Is there any way to reset the password???


Accepted Solutions (0)

Answers (3)

Answers (3)

former_member229568
Discoverer

Hi,

just found a way:-)

There is a folder named config\ with a file called users.xml.

Create your password as SHA-256 in capitals and paste the new password inside there.

Regards

Silke

Ulrich_Schmidt
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Silke,

in some releases it may need to be a SHA1.

Anyway, for those who are not familiar with creating hash-codes, here is a way to reset the SCC password to "manage":

  1. Stop the SCC (e.g. from the Windows Service Console or using the desktop shortcut).
  2. Open the config\tomcat-server.xml and search for the element <Realm>. If it consist of a single line with digest="SHA1", you need a SHA1 hash, if it has multiple lines and one of these has digest="SHA-256", you need a SHA-256 hash.
  3. Next open the config\users.xml in a text editor and look for the line with username="Administrator". If the SCC is using SHA1, set the password field like this:
    password="3F282FCBA8933E03A65A6DC92A27DE8396961E2F"
    If the SCC is using SHA-256, set the password field like this:
    password="181229424893BB65D94A74C2132B8B9E5ADFE851464FDB5CB9F49E8A8204BE7B"
  4. Save the users.xml and start the SCC again.

Best Regards, Ulrich

MarkusTolksdorf
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Silke,

the easiest way to get the initial credentials to extract the users.xml from a Developer version and replace the existing one. No edit necessary, no typos possible. After a restart, you you can use the initial SCC password and will be asked to change it immediately again.

Best regards,

Markus

Former Member
0 Kudos

Hey Ranjit

Please note that even the username is case sensitive, I also had the same problem, I thought i forgot the password. Then I tried with "Administrator" where "A" is capital and the password (i thought i had used) . it worked.

Anuj07
Employee
Employee
0 Kudos

Hi Ranjit,

I have doubt here since forgot password option is also not present

so only way you need to reinstall your cloud connector  and reconfigure it.

Best Regards,

Anuj

MarkusTolksdorf
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello Ranjit,

for the built-in users, there is no forgot password mechanism as it is only supposed to be used for a short time frame when initially setting up the SCC or in developer use cases, for which the Cloud Connector is only local to a developer workplace. In productive environments, it is recommended to setup LDAP integration, which then is using a user base external to Cloud Connector and in that user store such mechnisms will exist.

Best regards,

Markus

nick_scherer3
Participant
0 Kudos

hello Markus

I have problems here.

osgi> error: shell command for retrieving PID of process bound to SCC port failed

-- java.lang.NullPointerExeption

Exeption in thread *thread-4"

I can also send the log on the email if you need it.

many thanks for fast help.

Nick

MarkusTolksdorf
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Nick,

it seems that the secure store was not initialized correctly during installation - a reason is not ovbvious in the traces. It seems to have worked properly according to installation logs. However, when starting the port, the server certificate cannot be read as it fails to access the server certificate.

As itwas a fresh installation, the fastest approach to get a running system is probably to simply do a fresh installation.

Best regards,

Markus