cancel
Showing results for 
Search instead for 
Did you mean: 

SAP BODS 4.2 & ERP6: filter condition not applicable from BODS to Generic Extractor

former_member251899
Participant
0 Kudos

hi there,

I'm facing an issue where BODS 4.2 is suppose to extract data from a generic (custom) extractor in ECC (EHP4 ERP6) based on a filter condition. I see that the filter condition is being passed to the extractor from BODS (i verified that by looking at odqmon). Any guidance much appreciated in order to figure out the problem and solution. I have attached the screen shots as well, just to give you an idea.

P.S I have also tried to do the delta init without data from BODS. still no success to figure out whats wrong.

RSA3. Number of records available for ERDAT_VBAP = 20160101

extractor imported into BODS for the same criteria ERDAT_VBAP bw 20160101 & 20160101

an entry is created in odqmon the selection criteria here is the same, ERDAT_VBAP = 20160101

But when I goto the units screen in ODQMON is see alot more records as compared to RSA3 screenshot.

So the question is that why is the extractor working fine when using it from RSA3 but when BODS is calling it there is some issue and as a result of that its fetching alot many records.

Regards,

samique

Accepted Solutions (0)

Answers (0)