Showing results for 
Search instead for 
Did you mean: 

SAM 2210 - new Object - Select a key from the allowed namespace.

0 Kudos


I did some enhancement in an older Version of SAM. Now I want to update the version to SAM2210 and so I would like to add some custom oData Entities to the relevant service. Like in the past I have no issues with doing this in /syclo/configpanel. Until I want to define the key field in the property list. Whenever I want to create the key field, it comes back with the message: Select a key from the allowed namespace.

I tried a few things to sort this. For example I did create a new Application, all items start with a Z - does not help, I even tried to copy an existing entity - with the same result.

I get this error even in my S/4 Test installation. What do I have to do, to get rid of this error?

View Entire Topic
0 Kudos

Hi Oliver,

Please check out this SAP Note - There is a runtime parameter NO_NAMESPACE_CHECK which you could use to bypass the namespace check.



0 Kudos

Is there any way to find out what is the allowed namespace for such customizing objects?