cancel
Showing results for 
Search instead for 
Did you mean: 

SAC Planning: Locking on model dimensions locks "Totals" on a table

antonclv
Explorer
0 Kudos

Hi All

When manually locking cells on a table in a story, the "Totals" value is still enabled for change - i.e not greyed out and values can be entered at that level - either when using a hierarchy or flat structure and displaying "Totals".  (See pic below showing "Sep" & "Oct" cells locked, but the total value of 1,200 when using hierarchy or flat structure is not greyed out and values can still be entered)

antonclv_1-1716469450183.png

 

However, when enabling dimension locks on the model for "Sep" and "Oct", the values in the table for those months become locked (greyed out) but the "Totals" are now also greyed out and changes can't be made.

antonclv_2-1716469602641.png

Is this by design or am I missing something?

View Entire Topic
William_Yu
Product and Topic Expert
Product and Topic Expert

Hi antonclv

  Have you check below data locking in your modeler? 

Best regards, William 

William_Yu_0-1716521407284.png

 

antonclv
Explorer
0 Kudos

Hi @William_Yu - thanks for the reply, but yes, I already have that toggle enabled.

antonclv_0-1716533955962.png

 

William_Yu
Product and Topic Expert
Product and Topic Expert
0 Kudos

In this case, you should be able to enter data on parent node with mixed status children. At least it works with my scenario.  

Do you have any un-published data? I would suggest you revert changes if you have and start edit again. 

antonclv
Explorer
0 Kudos
@William_Yu - In the example I provided, there was unpublished data. But I see the behaviour is the same with both published or unpublished. I also only have the default driving dimensions (version & date) enabled.
antonclv
Explorer
0 Kudos
@William_Yu - as mentioned in the original post, the lock is not applied at the total level when I manually lock cells on the table. But when locking the montsh via the model driving dimensions, the totals are also locked. Can you confirm that this is not what happens on your side?
William_Yu
Product and Topic Expert
Product and Topic Expert
0 Kudos

Yes, I confirm it works for me. Probably you can also double check your table setting in the builder panel.

William_Yu_0-1716539909829.png