cancel
Showing results for 
Search instead for 
Did you mean: 

RTMFMessaging causes performance problem

Former Member
0 Kudos

Hi,

We have a performance problem with the component:

EP:KM:COLL:class com.sap.ip.collaboration.core.api.rtmf.core.RTMFMessaging.ReceiveJMSQueue

This component according to the Request overview is executing literally billions of requests each day. It is also not closing many of the requests. I wondered if anyone could give some hints as to performance settings for RTMF in a load-balanced landscape that would prevent this behaviour?

We have a Central Instance with 3 nodes, each running a web dispatcher and 4 application servers in a load-balanced environment - so it's meant to be a high availability Portal until this problem makes it fall over!

The symptoms are also that the performance degrades over time as the RTMF requests are not always closed, until they consume enough resources that the system stops responding.

Any help would be appreciated.

Thanks, Marc

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

In case you do not wish to use RTC functionality, and wish to disable it, there is a way to disable it via the portal.

Please follow SAP note no. 839154.

It includes a full description of how to disable \RTC on an EP6.0 portal system.

Best Regards,

Oren.

Answers (2)

Answers (2)

guillaume-hrc
Active Contributor
0 Kudos

We have the same problem. Is there any news on this subject.

It is weirdly occurring only on the Productive system.

Thanks in advance.

Former Member
0 Kudos

Hi,

Please read my previous answer. This does not indicate any problem.

Best regards,

Hadar

Former Member
0 Kudos

Hi

As one of the authors has mentioned previously this is not a problem but the way RTMF framework works. It has a polling mechanism that polls the server for messages.

By default this polling mechnism is set to Constant Interval which is set to 3 seconds. So the RTMF will poll the server for messages every 3 seconds. However, depending on the number of users etc this polling mechanism can be changed to Linear Interval or maximum HPS (see SAP Help for further information).

This can be changed under: System Admin > System Config > KM Content > Collaboration > RTC > RTC Engine > Polling Policy

You can certainly look at changing these! If you have changed this already and still having problems with the requests get back to SDN.

Cheers

Ankit

Former Member
0 Kudos

Hi Ankit,

If you are not making use of the Real Time Messaging functionality would you recommend turning it off? Is this even possible?

Thanks,

Simon

Former Member
0 Kudos

Hi Marc,

The code you mention does not caused performance problem. although it seem like it consume time - it is actually "sleep" in must of this time. The Receive message is called with time out, meaning it sleeps on the JMS Queue till a message arrived to the queue or till the time out pass.

Can you please explain what do you mean by "RTMF requests are close"?

Regards,

Hadar