cancel
Showing results for 
Search instead for 
Did you mean: 

Row Structure and dynamic drill-downs

Former Member
0 Kudos

Hi all,

When creating a query with a structure in the rows and adding another Char or drill-down, the system shows all entries of the Char/Drill-down under each element of the structure.

How can I avoid that?

Example:

Struc

Elem1

Elem2

Elem1+2

Elem3

with drilldown DD1,DD2 and DD3

The expected result is that DD1,2,3 should only appear accordingly, however what I get is

Elem1

DD1 value

DD2 blank

DD3 blank

and so on..

I tried zero suppression.. but didnt manage to get it right yet.

Thanks & Best Regards,

Eric

Message was edited by: Eric Niedling

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Eric,

Jeff is right:

Right click on the structure -> Properties -> tick 'Also Use Zero Suppression for Structure Elements' flag.

Best regards,

Eugene

Former Member
0 Kudos

Hi Guys,

Thanks for your fast response.

Activating the zero suppression for structure elements is almost doing the job.

Its actually doing a bit more, since it also suppress the structure elements.

I would like to display all lines of the structure no matter whether there is data or not.

I dont want to see additional empty lines when drilling down. Since certain products dont have data for the structure element/restriction.

In other words the system seems to build something like a cartesian product..

I kept on playing with the zero suppression but it doesnt work yet.

I am on BW3.1 patch 21.

Have a nice weekend!

Former Member
0 Kudos

Note: 857895/Support Pack 22

Former Member
0 Kudos

Hi Guys,

Again, thanks for your help.

This is not really what I was looking for... and unfortunately I am not allowed to import the support packages.

Let's see whether I can convince to go with the "very" dynamic solution of "disappearing" structure elements.

Jeff & Prakash, I hope you are fine with two points.

Thanks & Best Regards,

Eric

Answers (3)

Answers (3)

Former Member
0 Kudos

Hello Eric,

Did you get solution for this ? if yes pls. let me know how to solve.

I'm also facing the same issue now!!

Thanks in Advance,

Vasanth.

Former Member
0 Kudos

The OSS Note mentioned above does solve this problem.

Former Member
0 Kudos

we are already in BW 3.5 support package 14.but still its not working.

In BW 3.0b support package 28 it's working.

Can anyone help Regd. this ?

Regards,

-Vasanth.

Message was edited by: Vasanth

Former Member
0 Kudos

I have seen this many times and zero suppression has solved it everytime. Make sure you have zero suppression set for the query properties, as well as zero suppression set on the structure.

Thanks,

Jeff

Former Member
0 Kudos

There is an OSS Note in BW 3.1 SP21 or SP22 that fixes this that I ran across a while back. You can apply that note to fix this problem.

Former Member
0 Kudos

Hi Prakash,

I started looking for OSS Notes but could find something yet.

We are currently on patch level 21, will check the notes again.

Please send the Notes No. if you can find it.

Thanks & Best Regards,

Eric

P.S.: Browsing the notes to the Patches.. Note 823536 (Unnecessary display of leaf # in a presentation history ) is the best I can find...

Message was edited by: Eric Niedling