cancel
Showing results for 
Search instead for 
Did you mean: 

Route not found when using sap java buildpack for cloud foundry application

suresh12
Discoverer
0 Kudos

New to cloud foundry here. Trying to deploy a Hello-World Spring Boot Application on CF. The demo application provided here (and compiled with Java 😎 works without a problem. I click on the generated route and the result is there. But when I replace java_buildpack with sap_java_buildpack, the route returns "Not Found". What am I missing here?

The reason for using sap_java_buildpack is that when I deploy a DB binded app on CF with java_buildpack, it doesn't run (driver rejecting JDBC URL). But it reaches the started state with sap_java_buildpack, albeit with the same "Not Found" issue.

So, any help with either of the issues is welcome..

sangwan
Explorer
0 Kudos

Hi suresh12, Did we find and solution or root cause here?

View Entire Topic
CarlosRoggan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi,
sorry, unfortunately, I'm not familiar with java buildpacks.
Just wondering:
What exactly is not found? The REST endpoint? Or the route?
I can see in the manifest an outdated parameter: host.
I think it is deprecated and you probably should add something like

    routes:
    - route: sample-sapcp.cfapps.us10.hana.ondemand.com
Just little hint
sukhpreet_k68
Explorer
0 Kudos

The route itself is not found. Tried with the above change in manifest, but still the same. Thanks for trying though!