cancel
Showing results for 
Search instead for 
Did you mean: 

RFC between Production and development is not working

Appuru
Explorer
283

Hi All,

We have installed the Production BW system, and when we try to check the RFC connection between Production and Development, we encounter the following error:
But development to Production is working fine without any issue (i.e one way is working and other way is not working)

We also verified the Telnet connection with the gateway port between Development and Production and its working fine.

Appuru_0-1719247425953.png

Regards

Appuru

View Entire Topic
Kishan_D
Advisor
Advisor

Hello,

Please check if telnet originating from Production to Development works fine. It is possible that bi-directional connectivity is not enabled on the Firewalls. If the telnet from Production to Development works, I would suggest looking at the firewall logs (when testing the RFC) to check if it is not blocking the RFC call.

Regards, Kishan

Appuru
Explorer
0 Kudos
Hello Kishan,
Appuru
Explorer
0 Kudos
Hello Kishna
Appuru
Explorer
0 Kudos
Hello Kishan Telnet connection to the gateway port between Production and Development is working fine. Are you suggesting that we should examine only the firewall logs to understand why it is being blocked?
Kishan_D
Advisor
Advisor
0 Kudos

Hello,

There can be multiple reasons causing this issue and firewall block can be one of those. Does your Production system have multiple application servers and cluster setup for message server? Has the RFC been configured to call the correct message server hostname/port and server group? Have you tried the RFC by connecting to specific production application server and bypassing the message server?

If these are correctly verified, I would then suggest checking SAP Notes and links below:

500235 - Network Diagnosis with NIPING - SAP for Me

2507582 - 10054: WSAECONNRESET: Connection reset by peer - SAP for Me

ISSUE #2: Partner … not reached | SAP Help Portal

These suggest further checks to be performed. TCP/IP flow dumps and firewall connectivity logs need to be checked if everything from SAP application perspective has been checked/verified. Hope this helps.

Regards,

Kishan

Appuru
Explorer
0 Kudos
Hello Kishan , Please find my answer Does your Production system have multiple application servers and cluster setup for message server? The Production system does not have a cluster or any application server. Has the RFC been configured to call the correct message server hostname/port and server group? Yes Have you tried the RFC by connecting to specific production application server and bypassing the message server? Production system is a single system and does not have any application server
Kishan_D
Advisor
Advisor
0 Kudos

Hello, In this case I would request you to run the niping tests as well as per SAP Note 500235. If there are no issues shown in the niping tests, you would need to check firewall/TCP trace/logs. Also please raise an incident to BC-MID-RFC for further investigation. Thanks, Kishan