Showing results for 
Search instead for 
Did you mean: 

Reports in Subfolders

Former Member
0 Kudos

I am using Crystal Reports for Visual Studio with Visual Studio 2012. I have a webpage up and working just fine. We are trying to expand the site, so to keep things organized we are trying to move the reports and pages into different subfolders. I haven't moved my crystalreportviewers13 file from where is originally was but now I am getting either a Load Report Failed. I have tried leaving the .rpt files in the main folder and just moving all the aspx files to the subfolders but then I get a bobj undefined error. I have tried looking at other posts but can't seem to get this to work. Is there something that I am missing? Is it possible to view report that is located in a subfolder?

Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Hi Kelsey,

Just to make things simpler..

'Load report failed' is thrown when the app does not find the reports, '.rpt' files.

'Bobj is undefined' is thrown when the app does not find the Crystal Report viewer files.

I would suggest redeploying your app with necessary changes doe to your report location.

for more info see below docs.

Search through the forum, these issues have been discussed many times.

- Bhushan

Senior Engineer

SAP Active Global Support

Follow us on Twitter

Got Enhancement ideas? Try the SAP Idea Place

Getting started and moving ahead with Crystal Reports .NET applications.

Answers (1)

Answers (1)

Former Member
0 Kudos

I have rebuilt my webpage to point to where things are now located. I am still getting the following error...0x800a138f - Microsoft JScript runtime error: Unable to get value of the property 'value': object is null or undefined. The line it is pointing to starts with bobj so I am pretty sure it is the bobj undefined error. I have gone through all of the different documents on the forum and still can't figure it out. Is it even possible to use the Crystal Reports Viewer from a subfolder, or does it have to be in the root folder?