cancel
Showing results for 
Search instead for 
Did you mean: 

replicaton server oracle to oracle : ORA-01843: not a valid month

zulmach
Explorer
0 Kudos

T. 2014/11/03 08:46:54. (71):  Last command to 'orcltgt.orcltgt':

T. 2014/11/03 08:46:54. (71):  Output command: insert into SCOTT.SCT_TEST_B (NAME, ID, TANGGAL)

                         values ('AAAAAAAAAAAAAAA', 4001, '10/17/2025 08:41:49')

I. 2014/11/03 08:46:54.  Message from server: Message: 1843, State 0, Severity 5 -- '[ statement ][ orcltgt ]

                         ociStmt::Execute ORA-01843: not a valid month'.

H. 2014/11/03 08:46:54.  THREAD FATAL ERROR #5049 DSI EXEC(104(1) orcltgt.orcltgt) - dsiqmint.c(4723)

                         The DSI thread for database 'orcltgt.orcltgt' is being shutdown.

                         DSI received data server error #1843 which is mapped to STOP_REPLICATION.

                         See logged data server errors for more information.

                         The data server error was caused by output command #0 mapped

                         from input command #0 of the failed transaction.

I. 2014/11/03 08:46:54.  The DSI thread for database 'orcltgt.orcltgt' is shutdown.

here piece of the log.

running on solaris sybase replication server 15.7 using ExpressConnect for Oracle

replication agent on each side active oracle 11g and standby

try the same configuration on windows server all working

now iam clueless.

pls help.....

really appreciated

thanks in advance

zulmach
Explorer
0 Kudos

thanks for such quick reply mark,

forgot to mention that it is a warm standby replication configuration.

yes the same connection profile was used on both platform on both side (active/standby)

(using profile rs_oracle_to_oracle;eco)

exact input string for TANGGAL on both platform

exact NLS_DATE_FORMAT on both oracle

have tried to config solaris same date format string and nls_system/nls_session for date

and still not solved it.

pdb_convert_datetime set to false

tables are created by DDL replication so its the same datatype

should i try scripts on REP/scripts directory?

rs_oracle_to_oracle.sql

rs_oracle_to_oracle_eco.sql

hds_oracle_to_oracle_udds.sql

and some others...

tried it on windows platform and produce some other errors not related to errors before

so i reset the repserver configuration then it worked again.

not try on the solaris thou

Mark_A_Parsons
Contributor
0 Kudos

NOTE: My hetero-rep experience is limited to some ASE-to-Oracle table-level replication from a couple years ago, so fwiw ...

If repserver is sending the same exactly formatted string in the INSERT command to both standby databases then this would tend to imply the same translation is being used.

------------------

Can you manually (eg, via sqlplus) run the same exact INSERT statement (see the error message) against both Oracle standby databases?

If one fails and one succeeds then this would tend to indicate (at least to me) that the issue is with the Oracle configuration ... ?

Accepted Solutions (0)

Answers (0)