cancel
Showing results for 
Search instead for 
Did you mean: 

Relay Server and SMP 3.0 Integration

Former Member
0 Kudos

Hello,

I'm integrating a existing relay server with my new SMP 3.0 environment, I have followed these How-To guides: Using an Existing Relay Server Installation with SAP Mobile Platform - Administrator - SAP Library & and everything seems to be OK (although we are waiting the port to be open by Infrastructure team) but now I have a question: On SMP 2.x we must to configure two OE's for every SMP server: one for MBS and one for RBS. With SMP 3.0: Do I have to configure both? or just a MBS Outbound Enabler?

cc:

Best Regards,

MC

View Entire Topic
rakshit_doshi
Active Contributor
0 Kudos

Hi Marianna,

SMP 3.0 works on OData Concepts. So we do not require to use two different farms for MBS and RBS since there are not MBO's for synchronization.

Hope this helps.

Thanks,

Regards,

Rakshit Doshi

Former Member
0 Kudos

Hi guys,

I followed the guides and when I test the RSOE through Relay URL it says "services unavailable" as if the RSOE is not communicating with Relay and viceversa. I had changed a little bit the procedure because for Afaria is similar so what I did was the following steps: I configured the rs.config on my relay with my farm (SMP) and backend, copied the dbsvc feature (RSOE folder) of my relay on SMP machine, configure rsoe config file with the parameter of my SMP RSOE, create my windows services (creation was successful), start the service but... when I see the RSOE log on SMP machine it says the OE can't connect with relay (address:port/suffix)... and when I see the relay log on relay machine, this farm does not appear as engaged connection... I'm using Relay 16 with SMP 3.0 and connections is through SSL (443). My infrastructure team told me all seems to be right with the ports and firewall... but I want to know if there is something else I should do in order to make this RSOE work.

Best Regards,

MC

midhun_vp
Active Contributor
0 Kudos

What's happening when you are connecting with port 80 ?

I found it working myself. I am also with Relay 16.

Regards,

Midhun VP

rakshit_doshi
Active Contributor
0 Kudos

Hi Mariana,

Did the thing work for port 80. For Port 443 you need to connect to the HTTPS port of SMP. So for instance if your HTTP port is 8080 your https port will be 8081.

Thanks,

Best Regards,

Rakshit Doshi