cancel
Showing results for 
Search instead for 
Did you mean: 

Regarding loading failure into ODS

Former Member
0 Kudos
59

hai

i put the loading to ODS in background .(And one more thing , there is a Infocube on top of ODS).

But i put loading into ODS only and i got the following error .

<b>InfoIDocs missing; Database system

Diagnosis

InfoIDocs are missing. The Idocsim BW is created with the database systems as the source system. Since the IDocs are missing, a short dump in BW probably occurred.

System response

No selection information arrived from the source s

Procedure

Check the short dumps in BW.

Check the data in the InfoCube.

Troubleshooting

In the event that the data was updated correctly in the InfoCube, then it is possible that no Info-IDocs were created. In this case, manually set the entire status of the data request to "ok" (green traffic light) in the monitor in the Status tab page.</b>

And i checked the shortdump is ST22. It says that

SYSTEM_CANCELED

The program GP42KRYWBRNC1XNG520X004ZM1 was terminated manullay .

The curent prgram is terminated by another mode eg: transaction SM50.

SO pls tell me 'what is error means and what i have to do '??

i ll assing the points

bye

rizwan

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Question :

select equipment /bic/zpmtechid from /bi0/pequipment into

corresponding fields of table

int_equipment1 where objvers = 'A'. <i><b><< Is the record unique? This is probably going to extract heaps of records since there can be soooo much records that are active. Try to restrict more using the WHERE condition

sort int_equipment1 by /bic/zpmtechid equipment. In your strcutre there must be some indicative ID to uniquely identify the record....</b></i>

firstpckg = 'X'.

endif.

Clear : int_equipment1. <i><b><< You took so much time to load and clear?</b></i>

Read table int_equipment1 with key /bic/zpmtechid =

COMM_STRUCTURE-/bic/zpmleasst binary search.

If not int_equipment1-equipment is initial.

move int_equipment1-equipment to RESULT.

Endif.

Try load to PSA first and then check the data integrity.

Cheers,

Gim

Message was edited by: Gim Lee Koh

Answers (10)

Answers (10)

Former Member
0 Kudos

hai guys

thanks for giving the reply .

I put loading for some set of data(23,000). But i got the same error and loading taken 3 hours .

<b>InfoIDocs missing; Database system

Diagnosis

InfoIDocs are missing. The Idocsim BW is created with the database systems as the source system. Since the IDocs are missing, a short dump in BW probably occurred.

System response

No selection information arrived from the source s

Procedure

Check the short dumps in BW.

Check the data in the InfoCube.

Troubleshooting

In the event that the data was updated correctly in the InfoCube, then it is possible that no Info-IDocs were created. In this case, manually set the entire status of the data request to "ok" (green traffic light) in the monitor in the Status tab page.</b>

i have the code in UR:-

<b>I inserted one characteristic(0equipment) in ‘Data Fileds’ of ODS.

Then I writteen the following code in update tules for that new characteristic

data : begin of str_equipment occurs 0,

/bic/zpmtechid like /bi0/mequipment-/bic/zpmtechid,

equipment like /bi0/mequipment-equipment,

/bic/zpmletyp like /bic/mzpmleasst-/bic/zpmletyp,

end of str_equipment.

data: int_equipment1 like str_equipment occurs 0 with header line.

data : firstpckg(1).

If firstpckg is initial.

clear : int_equipment1.

refresh : int_equipment1.

select equipment /bic/zpmtechid from /bi0/pequipment into

corresponding fields of table

int_equipment1 where objvers = 'A'.

sort int_equipment1 by /bic/zpmtechid equipment.

firstpckg = 'X'.

endif.

Clear : int_equipment1.

Read table int_equipment1 with key /bic/zpmtechid =

COMM_STRUCTURE-/bic/zpmleasst binary search.

If not int_equipment1-equipment is initial.

move int_equipment1-equipment to RESULT.

Endif.</b>

so pls tell me wht i have to do ..

im totally confused

bye

rizwan

Former Member
0 Kudos

Hi,

i think Raj and Pradip is correct... the load has been cancelled due to manual cancellation or system shutdown. Try checking the source system too for the cancellation. In this case reloading should not be a problem.

Cheers,

Gim

Former Member
0 Kudos

Hi Rizwan,

Th "syntax check" as the name suggest is just meant for syntax check. The code even though it may be syntactically correct may fail due to incorrect logic or incorrect looping or nesting where the processor just runs and runs without proceeding to the next step.

My suggetsion would be that if you can paste the code here somebody should help you out.

Hope this helps.

Bye

Dinesh

Former Member
0 Kudos

hai pradic

I have ODS -> Infocube structure.

I included one data field in ODS and then i written the routine for that newly inserted characterisitc in URs of ODS in such a way that , it should get the data from other master data table .

ANd i checked the sytax.It is correct.

Then is there any problem in UR's routine eventhough the syntax of code is correct.

pls tell me yar

txs

rizwan

Former Member
0 Kudos

Hi Mohammed,

Check your update rules mapping and schedule your loading process to ODS.

Thanks,

Patric Thumma.

Former Member
0 Kudos

hai GIM

what wondering that Idoc's are processed and not reached.

ANd what i have to check in SM58 .

pls tell me yar

txs rizwan

Former Member
0 Kudos

hai dinesh

yaa i written the code in UR's .

That code have 'no syntax error'. I think , it is so fine .

what may be more...

pls tell me

txs

rizwan

Former Member
0 Kudos

Hi,

Was wondering if you found any IDoc that has been recorded but not processed? Use SM58 to check that.

Cheers,

Gim

Former Member
0 Kudos

Hi Rizwan,

Looks like your load got stuck in the update rules. Check the check update rules for any code written there.

Bye

Dinesh

Former Member
0 Kudos

Dear Mohammed,

Looks like the extraction process has been terminated manually.

Try scheduling it again and see.

Thanks,

Raj

Former Member
0 Kudos

make request RED in the ODS and then try to reload.

cheers,

Vishvesh

Former Member
0 Kudos

Hi

It seems extraction process got terminated due to one of reasons such as system shut down or someone cancelled the jobs/active process. Try loading again.

Regards

Pradip