Showing results for 
Search instead for 
Did you mean: 

Redwood Help

Former Member
0 Kudos

Hi All,

We are running script RSI_IMPORT_OUTPUT_DIVICESES to import SAP printers in Redwood and getting following error.

ORA-01400: cannot insert NULL into ("RSI"."RSI_SAP_PRINTERS"."TYPE")

ORA-06512: at "RSI.RSILIB", line 3254

ORA-06512: at "RSI.RSIEXEC", line 1118



ORA-06512: at line 1

ORA-06512: at "SYS.DBMS_SYS_SQL", line 1200

ORA-06512: at "SYS.DBMS_SQL", line 323

ORA-06512: at "SYSJCS.DDL", line 552

ORA-06512: at "SYSJCS.DDL", line 585

ORA-06512: at "SYSJCS.DDL", line 639

ORA-06512: at line 3

JCS-00215: in statement RSOJ_EXECUTE_JOB

Here the child script RSI SEARCH_OUTPUT_DEVICE is searching all the devices successfully.

being a ABAPer, I am new to Oracle and can only sense that the value of the printer type is not getting passed. But I do not understand on how to proceed. Are we required to change the procedure (or whatever in Oracle..-:)). If yes how to change it...

tried to google something and found this thread...

Thanks in advance for all your help and support.

Best Regards,


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Vithal,

This is basically a data issue. In SAP, where printers are maintained, there needs to be type specified for the printers. A Null value is not allowed for printer type in RSI_SAP_PRINTERS Table TYPE field in SAP CPS repository.

You can also check other not null fields by looking at keys of this table by looking at its definition in last node of the left hand side tree.

Hope this helps

- Bhuga

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi BHushan,

Thanks for your help. we were having one output device with blank output type. We removed the same in R/3 and this worked. Thanks.