cancel
Showing results for 
Search instead for 
Did you mean: 

Reducing the memory footprint of Sybase ASE

anand_sampath2
Participant
0 Kudos

Hello All,

We are doing a test install of SAP Solution Manager 7.01 on Sybase ASE 15.7.

Since this is just a test setup, we started off with a lower-than-recommended hardware configuration (4 GB RAM only) due to time constraints.

While post install performance of SolMan was decent, performance during solman_setup (setting up technical monitoring) has become appalling. We are not able to complete the configuration process at all as the SolMan configuration web application has become very unpredictable and extremely slow.

The SolMan install is centralized and on a windows 2008 box. Windows task manager shows consistent memory usage of up to 90 - 95%. We also tried reducing the total number of work processes to just 8 but that did not help much. We see in 'task manager > resource monitor' that sqlserver.exe process is committing close to 2 GB of RAM when in fact it seems to be using much lesser when seen directly in 'task manager > process tab'. Please tell us about any memory optimization we can perform for Sybase ASE in order to complete out Solman_setup. We were hoping that we could change the  'max memory'/'total logical memory' setting for the DB directly using DBACOCKPIT tcode but could not do so as the parameters seems to be read-only. We could not find much documentation regarding memory optimization for the DB. Please help out. Thanks!

-Regards,

Arvind

anand_sampath2
Participant
0 Kudos

Thanks Mark. I was incorrect in saying that max memory parameter was read only. In reality, It is indeed changeable but could not set it to a value below the total logical memory parameter. Total logical memory value was only very slightly lesser than the max memory and this is read only, thereby preventing me from reducing max memory any futher

Mark_A_Parsons
Active Participant
0 Kudos

To reduce 'max memory' you can try setting the new value and then bounce the dataserver. Upon startup the 'max memory' value would be applied first and then the 'total logical memory' setting will be reset/calculated based on the new 'max memory' setting.

If you're unable to set 'max memory' before shutting down the dataserver you'll have to a) shutdown dataserver, 2) update the dataserver *cfg file with the new 'max memory' value and 3) restart the dataserver.

Keep in mind that if you have more than 'max memory' memory allocated for other purposes (eg, data caches, proc cache, statement cache, user connections, etc) you may experience some problems during dataserver startup.  To address this issue you would need to increase 'max memory' or decrease some of the memory-related settings. ("Duh, Mark!" ?)

anand_sampath2
Participant
0 Kudos

We tried to reduce max memory in the DB server config file like you said Mark but the DB and SolMan work processes are not starting up in this case. Forced to leave max memory as it is. I had also posted this in the Apps on ASE forum like you said.

Hoping for a break

Thanks

Accepted Solutions (0)

Answers (0)