cancel
Showing results for 
Search instead for 
Did you mean: 

Recordset element in payload - ignoreRecordsetname (true) used

kanthimathikris
Employee
Employee
0 Kudos
53

Dear All,

The XML for my source at the design time reads as follows,

<?xml version="1.0" encoding="UTF-8"?>

<ns0:mt_sales_order xmlns:ns0="filerfc:xi">

<sales_data>

<sales_order>1234</sales_order>

<delivery_blk>01</delivery_blk>

</sales_data>

<sales_data>

<sales_order>12345</sales_order>

<delivery_blk>01</delivery_blk>

</sales_data>

</ns0:mt_sales_order>

The payload is as follows,

<?xml version="1.0" encoding="utf-8" ?>

<ns:mt_sales_order xmlns:ns="filerfc:xi">

<sales_data>

<sales_data>

<sales_order>28595</sales_order>

<delivery_blk>01</delivery_blk>

</sales_data>

<sales_data>

<sales_order>28594</sales_order>

<delivery_blk>01</delivery_blk>

</sales_data>

</sales_data>

</ns:mt_sales_order>

The recordset element is appearing in the payload; but I have used the ignoreRecordsetname to true in the configuration.

What else should I do to ignore the recordset element that appear in the payload.

Warm Regards,

Kanthimathi

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

ignoreRecordsetname is case sensetive ....

use "ignoreRecordsetName"

Answers (2)

Answers (2)

kanthimathikris
Employee
Employee
0 Kudos

Thanks Sunil.

Former Member
0 Kudos

Hi,

ignoreRecordsetName

A <Recordset> element is inserted in the XML structure for each recordset structure. This level is not always required, particularly if the recordset only contains one structure definition.

If you set the parameter to true, the <Recordset> element is not inserted.

and refer the following link

http://help.sap.com/saphelp_nw70/helpdata/EN/2c/181077dd7d6b4ea6a8029b20bf7e55/frameset.htm

Cheers

Veera