cancel
Showing results for 
Search instead for 
Did you mean: 

R3trans error

Former Member
0 Kudos

Dear

I'm unable to connect through R3trans -d to my database and please find below is the logs:

4 ETW000 173 0.003173

4 ETW000 [ dev trc,00000] function dsql_db_init loaded from library /usr/sap/ZS3/SYS/exe/run/dboraslib.o

4 ETW000 10 0.003183

4 ETW000 [ dev trc,00000] function dbdd_exp_funs loaded from library /usr/sap/ZS3/SYS/exe/run/dboraslib.o

4 ETW000 33 0.003216

4 ETW000 [ dev trc,00000] New connection 0 created 12 0.003228

4 ETW000 [ dev trc,00000] 000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 18 0.003246

4 ETW000 [ dev trc,00000] db_con_connect (con_name=R/3) 27 0.003273

4 ETW000 [ dev trc,00000] find_con_by_name found the following connection for reuse: 7 0.003280

4 ETW000 [ dev trc,00000] 000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 16 0.003296

4 ETW000 [ dev trc,00000] Got LIBPATH=/usr/lib:/lib:/usr/sap/ZS3/SYS/exe/run:/usr/sap/ZS3/SYS/exe/runU:/oracle/client/10x_64/instantclient:/oracle/ZS3/112_64/lib from environment

4 ETW000 230 0.003526

4 ETW000 [ dev trc,00000] -->oci_init1 13 0.003539

4 ETW000 [ dev trc,00000] Oracle Client Version: '10.2.0.2.0', (dbsl 701 131011, non-unicode) 50 0.003589

4 ETW000 [ dev trc,00000] Default connection: tnsname ='ZS3' 7 0.003596

4 ETW000 [ dev trc,00000] -->oci_initialize(con=0, char='WE8DEC', nchar='AL16UTF16', uc_ln=1) 7 0.003603

4 ETW000 [ dev trc,00000] Application info callback registered. 6 0.003609

4 ETW000 [ dev trc,00000] OCIEnvCreate(mode=0=OCI_DEFAULT) returned 0 (for default NLS handle)

4 ETW000 1425 0.005034

4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrHp=110a17ff8) 19 0.005053

4 ETW000 [ dev trc,00000] OCIHandleAlloc(OCI_HTYPE_ERROR, con=0, ErrBt=110a178a8) 8 0.005061

4 ETW000 [ dev trc,00000] NLS env.: lang=414D45524943414E 44 0.005105

4 ETW000 [ dev trc,00000] terr=414D4552494341 8 0.005113

4 ETW000 [ dev trc,00000] char=574538444543 6 0.005119

4 ETW000 [ dev trc,00000] Client NLS setting (by OCINlsGetInfo): con=0, 'AMERICAN_AMERICA.WE8DEC'

4 ETW000 11 0.005130

4 ETW000 [ dev trc,00000] charset='WE8DEC', ncharset='AL16UTF16', UNI_ASC=FALSE 6 0.005136

4 ETW000 [ dev trc,00000] Logon as OPS$-user to get SAPHP1's password 8 0.005144

4 ETW000 [ dev trc,00000] Connecting as /@ZS3 on connection 0 (nls 0) ... (dbsl 701 131011, non-unicode)

4 ETW000 10 0.005154

4 ETW000 [ dev trc,00000] Allocating service context handle for con=0 7 0.005161

4 ETW000 [ dev trc,00000] Allocating server context handle 7 0.005168

4 ETW000 [ dev trc,00000] Attaching to DB Server ZS3 (con=0,svchp=110a15218,srvhp=110a1af78) 39 0.005207

4 ETW000 [ dev trc,00000] OCIServerAttach(OCI_DEFAULT) failed with -1=OCI_ERROR 3343 0.008550

4 ETW000 [ dev trc,00000] OCIServerAttach(OCI_DEFAULT) failed with SQL error 12537: 23 0.008573

4 ETW000 [ dev trc,00000] ORA-12537: TNS:connection closed

4 ETW000 12 0.008585

4 ETW000 [ dbsloci.,00000] *** ERROR => CONNECT failed with sql error '12537' 9 0.008594

4 ETW000 [ dev trc,00000] set_ocica() -> SQL error code 12537 7 0.008601

4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con=0, rc=12537) 7 0.008608

4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 12537 6 0.008614

4 ETW000 [ dev trc,00000] ORA-12537: TNS:connection closed

4 ETW000 11 0.008625

4 ETW000 [ dev trc,00000] SAPUSER or connect error 99=DBSL_ERR_DB, oerr=12537. 7 0.008632

4 ETW000 [ dblink ,00433] ***LOG BY2=>sql error 12537 performing CON [dblink#4 @ 433] 314 0.008946

4 ETW000 [ dblink ,00433] ***LOG BY0=>ORA-12537: TNS:connection closed [dblink#4 @ 433] 9 0.008955

2EETW169 no connect possible: "DBMS = ORACLE

Regards,

PANU

View Entire Topic
Former Member
0 Kudos

Hi,

Please ensure that the listener is running.

The below link might help you resolve the issue.

http://forums.sdn.sap.com/post!reply.jspa?messageID=11127456

Regards,

Renu