cancel
Showing results for 
Search instead for 
Did you mean: 

Queue Management

Former Member
0 Kudos

Hi,

I'm having problems with a data load from R/3, but from a "Z" datasource.

the last data load went red with the following message:

ZFDEVF_02 queue does not exist in source system.

There is an infosource in BW and a datasource (Z) in the source system.

What do I do to (re)create the queue for a datasource?

I have 7 data loads to do in the exact same situation.

thanks for your help.

Mauricio.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

The tx RSO2 tells me

Infosource ZFDEVF_01 -> Transparent Table ZBI_EVHIST01

Tx SE11

I can see the table has 2333 records.

The ODS that will receive the data already has a Init load. I deleted it and try to load a new one, but now the Dump problem has arise. but the others infosources have a succesful init load in the ODS and the deltas keep showing "the queue doesnt exist in the source system"

I think the more I touch, the more I destroy.

the Dump problem prevents me for scheduling a new load.

Former Member
0 Kudos

in what stage ur getting the dump? can u just explain the message in dump? u can see it in st22.

Former Member
0 Kudos

Yeah u can go for re-init.

1. Delete all the content in the ODS.

2. Delete the init falg for the IP. you can do this in

double click on IP and then Scheduler -> initialize option for source system -> Selecxt the request and delete.

This will automatically reset the update mode into initialize delta process. since u r using a custom developed datasorce and not LO, u need not do anything in source system side. Just pull the request with init status. then we can try for delta. Hope ur able to solve ur problem.

Sriram

Answers (5)

Answers (5)

Former Member
0 Kudos

Sriram,

another thing,

I can not delete the init flag, because of the dump.

Is there any other way to delete the init flag, rather than going trhough the scheduler?

Former Member
0 Kudos

Sriram,

about the dump....

RSA1 -> Infosources

you find the infopackage, yo double clic on it, and you spect to see the scheduler, but you don't, you see the dump.

The dump indictes there was an error in the Source System

Short text of error message:

      • Data request to the OLTP ***

It seems to me that the program is trying to read something from roosprmsc table, but it doesn't find it.

that's what I can see from the dump report.

Former Member
0 Kudos

I think that I need a fresh start. I mean:

1.- delete all data in the ODS

2.- delete the init in the ODS

3.- set de datasource/queue ready to init.

How can I do the step 3? in BW or Source System?

what transaction houl I use?

Former Member
0 Kudos

Hi Sriram

Is ur load is delta or full?

is Delta.

Try extracting data from RSA3 and check.

RSA3 shows more than 1000 regs for delta init

RSA3 shows 0 regs for Delta.

Is your datasource in Source system is active?

I dont-n know how to check that.

and the tables/views associated with it are active ?

I dont-n know how to check that.

I did some actiation with two of tha datasource I need to load data from, and now they show a Dump every time I double clilc on the infopackage. The other info/datasources I haven't touch yet.

thanks for the help

Mauricio

Former Member
0 Kudos

So in RSA3, u are able to get the records for delta init. In the BW side, is delta been inited? Thats is there any request in the target with initialisation delta status?

You can goto transaction RSO2 and check wether ur datasource is saved and active there. in the same transaction, just check whats the source for the datasource, wether its a table or view and then goto transaction SE11 and check for the table entires. As u told ur delta init is picking records, there should not be any problem with this. In BW, just try to re-initiate the load. This should help you.

Regards

Sriram

Former Member
0 Kudos

Hi Mauricio

Is ur load is delta or full? Try extracting data from RSA3 and check. Is your datasource in Source system is active? and the tables/views associated with it are active ? please check all these and post back

regards

Sriram