cancel
Showing results for 
Search instead for 
Did you mean: 

Query on a Multiprovider

Former Member
0 Kudos

Hi Friends,

I have a BEx query on a Multiprovider(MP) that uses two InfoCubes. The MP is based on a basic InfoCube and a transactional basic Infocube. When i run the query, i cannot any data from either of the cubes. What could be the possible reasons.

Thanks

Raj

Accepted Solutions (1)

Accepted Solutions (1)

former_member188975
Active Contributor
0 Kudos

Hi Raj,

You can check the infocubes to see if there are any requests available for reporting. If your transactional cube contains just one request and it is yellow, then you need to include the 0REQID variable (not sure about the technical name but it is something like this). You need this variable in your filter area to get data fromthe yellow request.

Also check your query for any filters that may result in no applicable data.

You may also want to see the multiprovider definition to see if you have done the required identification and selection settings for key figures and chars.

Hope this helps...

Former Member
0 Kudos

Followup to Bhanu's post - 0S_RQMRC (Most Current Data) is the variable name. This will allow selection of an Open (yellow) request on the transactional cube. Otherwise, an Open request is not reportable.

former_member188975
Active Contributor
0 Kudos

Thanks Pizzaman

Former Member
0 Kudos

Thanks for the quick responses guys. i am trying all the possibilities that you suggested.

Best regards

raj

Answers (3)

Answers (3)

Former Member
0 Kudos

Thanks a ton to Bhanu and others who were prompt in their responses. The problem is resolved!!!

Raj

Former Member
0 Kudos

Hallo

I would also suggest to check you do not have any filter based on one IO which belongs only to one underlying cube. In this case you will not get any data.

Make a query on single cube and see if you get data.

Mike

Former Member
0 Kudos

Raj,

As Bhanu has suggested see if there is data in your multiprovider and it is available for reporting.

And once that is taken care of.

Run the query from RSRT in your BW environment to see if there are any issues with BEX.

If this is giving you results and your BEX still doesn't give you results..

try to play a rnd the filter a rea.

Best Luck.

-Led