cancel
Showing results for 
Search instead for 
Did you mean: 

Query Employee by ID - no results

lessip
Participant
0 Kudos

Hello everyone,

I tried to query an the BusinessObject Employee with a QueryByIdentification -> InternalID in the RepositoryExplorer in the Cloud Application Studio 1605 but I do not receive a result. To avoid misunderstandings - the Employee-BO to the ID I am querying really exists.

The analog BusinessPartner-Query with the corresponding ID works very well - but the Employee-Query has no result.

I also tried to query the Employee with a query, build in the UI-Designer. There, my result list also remains empty (message on UI: no records found)...

See the provided Screenshots.

What can I do, to receive the Employee-BusinessObject, belonging to the InternalID?

Best Regards,

Patric

Accepted Solutions (1)

Accepted Solutions (1)

sunil1101
Active Contributor
0 Kudos

Hi

Just try without any parmeter(internalID), it will give records. I tried and I can see records both with parameter and without parameters.

I guess what value you are trying to see is not maintain in Employee BO ( e.g. City and country code).

I have noticed issue with SalesPriceList BO QueryByElements, it does not returns any value. However for Employee BO it returns values.

Regards

Sunil

Answers (1)

Answers (1)

former_member186648
Active Contributor
0 Kudos

Hi Patric,

You could verify if it is Employee by executing the following query:
BusinessPartner -> QuerybyRole -> RoleCode = "BUP003" along with the Employee InternalID.

This should return data.

Thanks, Pradeep.