cancel
Showing results for 
Search instead for 
Did you mean: 

Prompting for parameters opens in IE

Former Member
0 Kudos

Hi there

I hope someone is able to assist with a problem we have been having for the last 2 years:

Certain of our machines are XP and other Windows 7 - our application uses Crystal reports which works well on XP. On the Win 7 machines the Prompting screen for parameters now opens with IE and no longer passes parameters to the reports to run.

I have Crystal 2008 which I use to develope reports and all works well in the report designer but when accessed by the application on a Windows 7 machine nothing works. I do not have access to the application source code but think it is using the runtime files installed with Business Objects XI.

c:\program Files (x86)\Business Objects\Common\3.5\

I think it has something to do with security settings but cannot find any solutions from Microsoft

The only reference I have found to this problem was a discussion/message posted on this forum :

http://scn.sap.com/message/13392151#13392151 - I have tried this process as detailed without any success on various machines

Any help would be really appreciated.

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Can you check if UAC is the probable reason:

htpp://windows.microsoft.com/en-IN/windows7/products/features/user-account-control

Thanks,

Prathamesh Acharya

Former Member
0 Kudos

Thanks Prathamesh

UAC is already set to - "Never Notify" and user has administrator rights - still no luck

Regards

Anthony

former_member183750
Active Contributor
0 Kudos

Hello Anthony

As this query is more to do with the CR SDK I moved the post to the "SAP Crystal Reports, version for Visual Studio" SCN Space.

based on this statement:

I do not have access to the application source code but think it is using the runtime files installed with Business Objects XI.  c:\program Files (x86)\Business Objects\Common\3.5\

I am not sure that we will be able to help. In a sense, it's like asking your car mechanic to fix your car, but you have mo idea if it is a Ford or a Ferrari and the hood is sealed so you have no idea how the thing moves (gas, diesel, antimatter, etc...).

Now based on this:

Prompting screen for parameters now opens with IE and no longer passes parameters to the reports to run.

I do not think the issue is related to permissions. Permissions would typically prevent the display of the parameter prompt or the activeX print dialog. But would not prevent values from being passed from the parameter screen to the report engine. E.g.; there is some other issue, possibly related to the API implementation (and this is where the sealed hood comes into play). How do we unseal the hood? We don't. You'll have to go to the author of the application and get them to help you out. They can in turn come to us and get help with their implementation.

- Ludek

Follow us on Twitter

Got Enhancement ideas? Try the SAP Idea Place

Share Your Knowledge in SCN Topic Spaces

Former Member
0 Kudos

Thank you very much Ludek

The application was written using Power Builder 8. I will forward this to them and advise the outcome.

Kind regards

Anthony

Former Member
0 Kudos

Hello Ludek

Thanks again for the help, I forwarded the info to the developers. The application is actually being done in Power Builder 11.5 and the Crystal Active X controller is 11, below is some of the code from the reporting function in Power Builder:

global type nvo_crystal_reports from n_object
end type
end forward

global type nvo_crystal_reports from n_object
end type
global nvo_crystal_reports nvo_crystal_reports

type variables
OLEObject  iole_crx_application

OLEObject  iole_crx_report

OLEObject  iole_crx_connection_info

OLEObject  iole_crx_export_options

// used for parameter setting
OLEObject iole_crx_ParameterFields
OLEObject iole_crx_ParameterField
OLEObject iole_crx_ParameterDiscreteValue
OLEObject iole_crx_ParameterFieldDefinitions
OLEObject iole_crx_ParameterFieldDefinition
OLEObject iole_crx_database_table
OLEObject iole_crx_Database

string is_ole_application_name = 'CrystalRuntime.Application.11'

// load report
iole_crx_report = iole_crx_application.OpenReport(as_report,Integer(as_operation))

// validate
if NOT IsValid(iole_crx_report)  then
is_error = "ERROR: OpenReport failed !"
return -1
end if

public function integer uof_instanciate (boolean ab_instanciate);

integer li_ret_value
string ls_db_parm, ls_connectstring, ls_dsn

// set defaults
is_error = ""
li_ret_value = 0

if ab_instanciate then

iole_crx_connection_info = create OLEObject
iole_crx_export_options = create OLEObject
iole_crx_application = create OLEObject
iole_crx_report = create OLEObject
itrx_database_info = create transaction

// connect
li_ret_value = iole_crx_application.ConnectToNewObject(is_ole_application_name)

if li_ret_value < 0 then
 
  is_error = "ERROR: Unable to connect to Crystal report Application !"
 
end if

Still no luck in getting parameters passed to the report, what is of interest is that the workstation has now been upgraded to IE 10 and the problem has changed - the Parameter Prompting Box now does not work at all, see screenshot below:

The report hangs at this point.

Thanks

Anthony

Answers (0)