cancel
Showing results for 
Search instead for 
Did you mean: 

Process Chain Bug

amine_lamkaissi
Active Contributor
0 Kudos

Hello experts,

Perhaps this subject was already treated, I canu2019 find any answer in SDN, for this reason I am posting my question here.

I have an issue with a process chain, when I launch it, I see the job in transaction SM37, it is reported like finished.

When, I see the logs of the process chain in transaction RSPC, it is reported like always running (with yellow color...).

Few hours ago, When, I try to launch it a new time, I have a message (PC still running from last run)

How can I fix it please?

Many Thanks.

Best regards.

Amine

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Amine,

If you launch your process chain, BI_PROCESS_TRIGGER immediately will get complete.

What are all the steps you have in your PC?

Which step is running at present ?

Check the status of the step(which is in yellow) by going into process monitor(right click on step and select process monitor) and check the job log.

If you still want launch the PC again, simply press yes when you get pop-up.It ends your PC last run and starts new one.

Regards,

Venkatesh

amine_lamkaissi
Active Contributor
0 Kudos

Thanks to all for your answers.

I fixed my problem by selecting process monitor, i choosed the yellow step and i set it into finished.

Now the process chain is all in green.

Thanks a lot.

BR.

Amine.

Answers (2)

Answers (2)

former_member182470
Active Contributor
0 Kudos

Hi ,

Probably your PC has been running since you launched. Right click on the step and look into Display Messages. You will come to know about the problem.

Please do not launch again and again till it gets completed.

Check if any RFC , Idocs problems are there with BASIS team.

If you feel the process complete internally, then you can make it to green manually. There are many threads which talk about this.......

Regards,

Suman

Former Member
0 Kudos

Hi,

If that process is loading process then check in the details tab and if data loading is completed then manually change the request status from yellow to Green.

This problem might come if there are any pending IDOCS in BD87 or if TRFC's are stuck in source system.

Regards,

Durgesh.