cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with power builder 11.5 or power builder 2017 and end support microsoft internet explorer

0 Kudos

hello

we have a problem in power builder 2017 or power builder 11.5 with internet explorer and edge.

Using the ole_browser object of type microsoft web browser and using microsoft internet explorer as web browser it works and we can upload files to a java servlet connecting as follows

ole_object_upload.object.connecttonewobject("InternetExplorer.Application")

ole_object_upload.object.Navigate(ls_url,0,4,lblobParam,lBlobHeader)

ole_object_upload.object.disconnectobject( )

being ls_url the URL of the servlet, for example "https://xxxxxxxxxxxxxxxxx", in the BLOB field we send the attached file

However, disabling Microsoft Internet Explorer in Windows 10 and setting Microsoft Edge as the default browser and enabling Edge Compatibility Mode with Microsoft Internet Explorer works randomly and does not give any errors.

We have tried to Change this: connecttonewobject("InternetExplorer.Application") by connecttonewobject("Edge.Application") and it doesn't work or give an error

thanks

jerryjanda
Community Manager
Community Manager
0 Kudos

Welcome to the SAP Community. Thank you for visiting us to get answers to your questions.

Since you're asking a question here for the first time, I'd like to offer some friendly advice on how to get the most out of your community membership and experience.

First, please see https://community.sap.com/resources/questions-and-answers, as this resource page provides tips for preparing questions that draw responses from our members. Second, feel free to take our Q&A tutorial at https://developers.sap.com/tutorials/community-qa.html, as that will help you when submitting questions to the community.

I also recommend that you include a profile picture. By personalizing your profile, you encourage readers to respond: https://developers.sap.com/tutorials/community-profile.html.

Now for some specific suggestions on how you might improve your question:

* Outline what steps you took to find answers (and why they weren't helpful) -- so members don't make suggestions that you've already tried.

* Share screenshots of what you've seen/done (if possible), as images always helps our members better understand your problem.

* Use the "insert code" feature when sharing your code, so members have an easier time reading.

Should you wish, you can revise your question by selecting Actions, then Edit.

One last thing: The inclusion of your personal email address violated our rules of engagement (https://community.sap.com/resources/rules-of-engagement), so I had to remove.

I hope you find this advice useful, and we're happy to have you as part of SAP Community!

All the best,

--Jerry

Accepted Solutions (0)

Answers (1)

Answers (1)

chris_keating
Advisor
Advisor
0 Kudos

AFAIK MS Edge does not have an OLE based interface. What I read on Google is that Edge IE compatibility mode does not include the ability to use OLE. You may want to ask this question in Appeon User Community as it is a more active forum and can address PB 2017 which they are the vendor.