Showing results for 
Search instead for 
Did you mean: 

Problems opening Xcelsius file (Xcelsius 2008 SP4) from a trial version

Former Member
0 Kudos


I am trying to open and update a xcelsius file (xlf) that was made on a trial version by a student. I used Xcelsius 2008 when I first tried opening it and got this message:

"This file was created with a newer version of Xcelsius (Xcelsius 2008 SP4), and is not compatible with the version installed on this machine. Before you can open this file, you must upgrade to the latest version of Xcelsius."

Now I have upgraded my Xcelsius to SP4, as it asked me to, and also tried changing the file to fit with my old xcelsius ( but nothing has worked. It still gives me the same message.

I have tried finding information in SAP notes but have not been able to log on to get Sap´s online help. I have also used the web to search for answers but been unsuccessfull so far.

My version of xcelsius is Xcelsius Engage

So, has anyone had a similar problem and has a suggestion of how I could open the file?

Thank you so, so much for the help!

Best regards, Hrefna

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Thank you for your answer!

I will try this, on another computer (as I use my licenced version alot in my computer).

Thanks for taking the time to answer me!

Best regards,


0 Kudos

There is a post at about how to open xlfs with older version of Xcelsius, in case it helps.

Former Member
0 Kudos

Hai From Latest Version of Xcelsius SP4 Once u Open the file in Sp4 , u cant able to open that file again in SP3

Former Member
0 Kudos


Please try to Remove the Previous Version of Xcelsius

Then try to Install Flash Player

Excel 2003/2007

Then try to Install

Xcelsius 2008 SP4 from trial Version



Fix 1:

After installing the software, run Xcelsius once under the administrative user who installed the software. This user will be prompted to enter the keycode and has permissions to write the keycode to the registry. Non-administrators can read the registry key and run Xcelsius.

Fix 2:

Logon to the machine with administrator rights.

Run regedit and go to the key u201CHKEY_LOCAL_MACHINEu2013> SOFTWARE u2013> Business Objects u2013> Suite 12.0

Right click on Suite 12.0 and choose Permissions.

Grant Full Control to the Users group for this key.

Non-administrators can now write to the key and enter the keycode themselves.

Assign Points it it is Useful

Deleted posted Product keycodes

Edited by: Vitaly Izmaylov on Oct 20, 2011 4:25 PM