cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with SetFullState and Datastore residing in NVO objects in PB 11.2

dukejw
Explorer
0 Kudos
126

Our program consists of a Main window holding all of our NVO objects for retrieving/updating data.  References to the NVO's are passed to the userobjects located on the window.  The NVO has 2 datastores - for static and non-static data - we exclusivley use external datawindows due to a screen scraper we use to access our mainframe.

The issue comes in for a special set of objects.

We have 1 set of objects that we can only retrieve/update 1 screen at a time.  The entire window is layed out as 1 row where each row/column is an individual cell so that I can 'describe' the properties to show which cells are actually editable.

The data is retrieved and stored in the datastores in the NVO and shared with the datawindow in the UserObject for display and interaction.

The user can page forward and backward through the screens and I set up a paging system such that I use getfullstate for each 'page' and store the blob so that we do not have to re-retrieve any page we already looked at for an account.  If they page backward (or forward to an already retrieved page I use setfullstate to show the correct data.)

The paging using this can cause the datastore and datawindow to be out of sync, but the end user is unaware because they only see the datawindow.

the problem comes in when they do an update.  I use the setfullstate on the datastore from the datawindow to ensure the correct data is updated, which works fine, but when I then try to retrieve and show the data after that step - the DS appears to have no data even though I verified the retrieve is returning data.

I have tried reestablishing the sharedata as setfullstate can destroy it, but it still doesn't show anything.  I tried passing in the NVO again to no avail.

It looks like the DS in the NVO is not receiving any data after I do a setfullstate - has anyone ever seen this before or am I missing somethng?  I haven't been able to find anything browsing the forums or googling.  Any help is appreciated.

VR,

jeff

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Jeff;

  Can you tell us ...

1) Version of MS-Windows you are using?

2) Build of PB you are using?

3) Did this problem just start happening?

4) Any recent changes to your application's DWO's?

5) Could this be a problem of duplicate DWO's from a temporary PBL in the library path?

6) Any other relevant information around this issue?

Regards ... Chris