cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with query display

Former Member
0 Kudos

Hi All,

Whenever, I try to display the queries ( Few not all) all key figures are shown with ~ sign prefixed and suffixed e.g. 21 is shown as 21 in Excel. However it doesn’t happen all the times. Some times this sign doesn’t occur at all. Has anyone else encountered this problem .If yes, what’s a remedy?

Thanks & Regards

PB

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

PB

Please look at Note: 591504 which fixes your issue.

Thank you

former_member188975
Active Contributor
0 Kudos

The note mentions exactly what I had to do to get rid of the ~ , and with us the problem happened with the Travel Management queries, even though we were on a higher support pack.

Former Member
0 Kudos

Hi P B,

Have you figured out:

1. what kind of KFs are displayed wrong (I mean with currencies, units of measure, without those)?

2. When you are saying that the situation doesn't happen all the times do you mean that one query result may be shown with tilde and without it during different query runs? If so, where selections, filters, drilldown etc. the same? Could you find out what was different in these runs?

Maybe some particular queries always show tilde and the others - not?

Best regards,

Eugene

Former Member
0 Kudos

Eugene ,

What you are saying is correct. Keeping everything in the selection criterion same. The same query when executed different times appears with and without tilde (~ symbol). Moreover its a SAP Standard query which is activated with no changes made to it.

There are few queries which never shows tildes (~). However there are some which some time show it and some time they dont.

I think problem lies in Activex Component in Excel. thats why I wondered if any faced this sort of situation in the past.

Cheers

PB

Former Member
0 Kudos

P B,

I've never met such a situation like yours. It was another one, when some key figures (for, example with value 12345) was shown as text (1234500000000000 - 16 symbols length).

Frankly, I don't remember how we get rid of it. It was something rather simple: restart BW-server, clear cache... Something like this.

Best regards,

Eugene

former_member188975
Active Contributor
0 Kudos

Hi P B,

Are you using business content queries? I faced this problem with some business content queries, and tried to figure out if it was an excel problem...no luck there, so I just did a Save As for the queries and then they were fine.

Former Member
0 Kudos

Thanks Bhanu,

I am using Business Content Queries. If there is no other option I will have to follow what u have done.

Thanks again

PB

Former Member
0 Kudos

Hi PB,

I think you have some problem with your SAP GUI Windows patch version...try to do a search in OSS note with "~" and "BW"...

Hope it helps !

Bye,

ROberto

Former Member
0 Kudos

Roberto,

Tried searching SAP Notes before posting this query, but no luck.

PB

Former Member
0 Kudos

Hi,

If you are using 'DELTA' data function in the respective Calculated key figure,Try to execute the query witout this function(in the defination of that calculated kf).

With rgds,

Anil

Former Member
0 Kudos

Thanks Anil,

But I am not sure what do u mean by Delta Data Function? Because I cant see Delta as data function in KF Edit Mode.

Or do u mean delta extractor?

Thanks

PB

Former Member
0 Kudos

Hi,

I faced this problem few days back.The problem was occured at a calculated key figure.

Fortunately the problem was solveed by removing the "DELTA" operator in the formula's denominator.

I hope this may not be the complete solution for the problem .Test it .

With rgds,

Anil