cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with database

Former Member
0 Kudos

I have changed some of my reports into a new DB. till yesterday everything was working fine but today the views are not pointing to the primary keys.

When I check in the Database(SQL) evrything works fine but it is not working with the crystal reports.

What could be the problem.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Did that too but didnt work

Former Member
0 Kudos

To be sure shot Reports that have passed as of last night and that are normally loading they are no longer loading right now..some fields are not showing up in crystal reports but are in the database

abhilash_kumar
Active Contributor
0 Kudos

Hi,

Has anything on the database changed?

Could you do a 'Verify database' (Go to the Database option in CR designer > Verify Database) and see if it helps?

-Abhilash

Former Member
0 Kudos

Its like

I have a column X in database. When I run a query in the DB it shows up. But when I do the same in the Crystal reports it reports that field X is unmapped

abhilash_kumar
Active Contributor
0 Kudos

So, you're saying that you changed the datasource of the reports to Database B from Database A; it worked fine until yesterday.

Now, some fields are missing and it gives you an option to Map fields?

Are all the fields available when you create a new report?

Could you try changing to ODBC/OLEDB/Native?

-Abhilash

Former Member
0 Kudos

Try changing ODBC????

abhilash_kumar
Active Contributor
0 Kudos

No, if you're using ODBC try changing to OLEDB or Native or the other way around.

And, what database is it?

-Abhilash

Former Member
0 Kudos

Yup I even tried that. But now the report shows numerous values and duplicates

I am uusing SQL

0 Kudos

It would really help a lot if you provide all of the info. 8 replies with nothing more than yes and no....

What version of Crystal Reports are you using?

Any patches installed?

What version of MS SQL Server?

How are you connecting and what Client Driver are you using, OLE DB or ODBC or JDBC?

Which Client dll are you using, SLQNCLI, SQLNCLI10 or the drviers included with MDAC?

What do you see if you create a new report, are all of the fields there?

What happens if you check off everything except Tables in the connection Options?

Don

Former Member
0 Kudos

We are using Crystal 08 and the server is SQL server MS08

we are connecting using the ODBC with SQL native client 10.

Even though we are developing some reports from scratch some of the fields are not showing up

if I write the same query in SQL server I get all the values.

I am unable to know why certain fields are not showing up.

0 Kudos

Can you get the SQL to create the table and paste in the info for the fields, field name and type, that are not showing up and some sample data?

I'll add the fields to my test DB and see what happens.

Thanks

Don