cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with barcode font

Former Member
0 Kudos

I am designing a report using Crystal Reports 2008 SP1. I am using the built in barcode fonts from Azalea software, the Code39 font, to produce a barcode from a database field. I added the data field to the report and used the "convert to barcode" function without doing anything else.

I have one record where it prints the barcode and the barcode is scannable. The data in the field is:

777+010002109+5+1+011013+

However, I have another record where the barcode prints but it is NOT scannable. The data in the field is:

XYZD-01+010002109+9+1+011013+

I did read on Azalea's site that I may need to add an asterisk (*) at the beginning and end of the data field for the start and stop bars. I tried this and it didn't print the barcode at all in either of the cases.

It seems like it doesn't scan when there are alpha characters in the data. Code 39 supports these though... What could I be doing wrong to cause the barcode not to scan?

View Entire Topic
Former Member
0 Kudos

Have you received any further information to solve your problem? Our items on our Crystal Report are not scanning either if there are alpha characters.

Joni

Former Member
0 Kudos

Joni,

Unfortunately, we were not able to resolve this issue with Crystal. We used a third party barcode font and it worked fine.

Former Member
0 Kudos

So did you purchase a third party font to use with Crystal? Or, what was your work-around?


Joni

Former Member
0 Kudos

Yes, we purchased a third party barcode font from ID Automation.