cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with a Bex Report

Former Member
0 Kudos

Hi Friends,

In a Bex Report, when i executed it for the first time

it had upto 7 variables, in which i entered the input for 3 of the mandatory fields and executed the report,

now the problem is .... for the 3 variables which i entered the values , the query is not asking for input when i executed it for the second time( not showing them in the variable list) , it has taken the values which i gave for the first time , if i am executing the query it is showing thye result for the values which i entered for the first time ,

so i am not able to run the report for other values,

But the same report is working fine in my friends login,

Please suggest me how i can make those variables again in my variable list ,

Thanks for any suggestions,

Raky

Accepted Solutions (1)

Accepted Solutions (1)

Ashwin
Active Contributor
0 Kudos

Hi rakesh!

Welcome to sdn...

Its might be because of personalization of the values in Bex analyzer. once opened a query you can change the values of vriable by selecting the option "change variable values" under the "change query ".

there you can see the option to personalize the value( which is shown with the symbol with a face or ctrl+F8) i think it asks you to delete the old values if you already have a personalization for this variable.

it must work...

(award points to helpful answers .....)

with regards

ashwin

Former Member
0 Kudos

Hi Ashwin ,

Graet yar.. Its working now i am able to change and execute the report,

Thank you very much for a timely help,

Raky

Ashwin
Active Contributor
0 Kudos

Hi Rakesh!

you are always welcome.

with regards

ashwin

Answers (3)

Answers (3)

former_member184494
Active Contributor
0 Kudos

What you have done is , you have set up personalization. That is the reason why the input is not being asked.

Set the option as mandatory input in variable definition.

Arun

Former Member
0 Kudos

Hallo

If you got some personalitation, you do not get again the Variable. In this case, go to Change on the Bex Bar and select Change Variable Values. In this case, all the Variables Pop up turn on.

Regards

Mike

Former Member
0 Kudos

Hi,

Have you checked that the variables have been defined as "Ready for input".

With rgds,

Anil

Former Member
0 Kudos

Hi Anil,

I hane already checked it , its OK,

Thanks for suggestion,

Raky