cancel
Showing results for 
Search instead for 
Did you mean: 

Problem while loading data in Material Attribute Data Source

Former Member
0 Kudos

Hello Experts,

I am facing a problem while loading data into Material Attr Info Object. While running an info package there is no issue. It is a Full Data Load. In PSA records are coming fully. But When I run DTP then I am getting error. Please find the attached screen shot for the error.

I can see 7008 Records in the error Stack. When I went in detail I just Found One Material with Space on the starting of it. For all other Materials it is showing the following Error.

Where as I did not find any duplicate records for the Same material. In other words there are no errorneous records in my case. I don't know what is going wrong and why can I see so many records in Error stack. Can any one please guide me on the above issue?

Issue is really urgent since I am not able to load data in my PRD system since 5 days. Appreciate your help.

Thanks&Regards,

Foram Shah

Accepted Solutions (0)

Answers (6)

Answers (6)

Former Member
0 Kudos

Hi Shah

In your case one of your InfoObject is having an invalid characters might be lower case letters issue.

once check the error description .one of your infoobject like 0MANU_MATNR is having a lower case letters or invalid characters.

If you have permissions , Try to maintain ALL_CAPITALS  in RSKC.

Else write a field routine by making it as upper case letters for this and run the DTP.

might be it will be helpful .

Regards,

DJ.

Former Member
0 Kudos

Hi DJ,

I have all the Material ID's maintained in Capital only. Even that is also not the issue.

Regards,

Foram

former_member189845
Active Participant
0 Kudos

Hi Foram,

Suggest you to enable the duplicate handle records options and also could you please tell that is there any semantic keys enable in DTP ?

Thanks,

Siva

former_member976
Active Contributor
0 Kudos

Hi,

can you enable the semantic keys at DTP stage?

then load the data and try it.

or

create the new DTP enable the duplicate handle records option

now it will work

Thanks,

Phani.

former_member223526
Participant
0 Kudos

Hi

Delete the entire data from the target and run the DTP using the Handle duplicate key option enabled.

Thanks,

Madhu.

jay_reddy1
Active Participant
0 Kudos

HI,

Delete all data in PSA except latest one.

Delete all data in Data target and repeat the DTP

Hope it helps you.

Former Member
0 Kudos

Hi Foram,

How many records have you got in the last load in PSA?. Are you doing a delta load from DTP? If it is full, see if there are more loads in PSA.

Regards,

Gorka.

Former Member
0 Kudos

Hello,

Its a full load from DTP. There are 77,000 Records Approax in the PSA last load. and there are no more loads in PSA.

Regards,

Foram

Former Member
0 Kudos

Hi Foram,

I know that you have said that there are not duplicate records, but try to go to DTP, in Update tab check "Handle Duplicate Record Keys". Activate it and execute.

Regards,

Gorka.

former_member186053
Active Contributor
0 Kudos


Hi Foram,

If you are sure no more requests in PSA other than latest one and also no old data in 0material, please try with the option given by Gorka.

Thanks,

Vengal.

Former Member
0 Kudos

Hi Gorka/Vengal,

I tried the above option too. But not working in my scenario.

Regards,

Foram

Former Member
0 Kudos

Hi again,

The unique thing that you can do is delete and recreate a new DTP.

Regards,

Gorka.